summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore14
-rw-r--r--debian/.gitignore3
-rw-r--r--debian/changelog16
-rw-r--r--debian/compat2
-rw-r--r--debian/control11
-rw-r--r--debian/copyright2
-rw-r--r--debian/docs2
-rwxr-xr-xdebian/rules8
8 files changed, 45 insertions, 13 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..eb2b489
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*/*.d
+*/*.o
+GNUmakefile
+Makeconfig
+hide-game
+include/bsd-games.h
+install-man
+install-score
+rogue/pathnames.h
+rogue/rogue
+rogue/rogue.6
+subst.rules
+subst.sed
+
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 0000000..7405b59
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1,3 @@
+bsdgames-nonfree*
+debhelper-build-stamp
+files
diff --git a/debian/changelog b/debian/changelog
index 1013f05..3620386 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+bsdgames-nonfree (2.17-8) unstable; urgency=medium
+
+ * debian/compat: Advance to Debhelper 11 (from 9).
+ * debian/control:
+ - Bump debhelper requirement to (>= 11~) accordingly.
+ - B-D on libncurses-dev, not transitional libncurses5-dev.
+ - Repoint Vcs-* at salsa.
+ - Explicitly indicate that binary targets require (fake)root (because
+ the executable is setgid games).
+ - Standards-Version: 4.3.0 (compliant at this point).
+ * debian/copyright: Note my 2019 contributions.
+ * debian/{docs,rules}: Swap roles of ChangeLog and NEWS.
+ * debian/rules: Take advantage of /usr/share/dpkg/buildflags.mk.
+
+ -- Aaron M. Ucko <ucko@debian.org> Thu, 28 Feb 2019 22:30:25 -0500
+
bsdgames-nonfree (2.17-7) unstable; urgency=medium
* debian/control: Canonicalize with the help of cme fix. In particular,
diff --git a/debian/compat b/debian/compat
index ec63514..b4de394 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+11
diff --git a/debian/control b/debian/control
index ae6cabf..75a411b 100644
--- a/debian/control
+++ b/debian/control
@@ -3,11 +3,12 @@ Maintainer: Aaron M. Ucko <ucko@debian.org>
Section: non-free/games
XS-Autobuild: yes
Priority: optional
-Build-Depends: debhelper (>= 9),
- libncurses5-dev
-Standards-Version: 3.9.8
-Vcs-Browser: https://anonscm.debian.org/cgit/users/ucko/bsdgames-nonfree.git
-Vcs-Git: https://anonscm.debian.org/git/users/ucko/bsdgames-nonfree.git
+Build-Depends: debhelper (>= 11~),
+ libncurses-dev
+Standards-Version: 4.3.0
+Vcs-Browser: https://salsa.debian.org/ucko/bsdgames-nonfree
+Vcs-Git: https://salsa.debian.org/ucko/bsdgames-nonfree.git
+Rules-Requires-Root: binary-targets
Package: bsdgames-nonfree
Architecture: any
diff --git a/debian/copyright b/debian/copyright
index 658fc6d..8502417 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -12,7 +12,7 @@ License: BSD-3
Files: .gitignore config.params debian/*
Copyright: Copyright 1997-2000 Joey Hess <joeyh@debian.org>,
2001-2003 Javier Fernandez-Sanguino Peña <jfs@computer.org>,
- 2003-2013, 2017 Aaron M. Ucko <ucko@debian.org>
+ 2003-2013, 2017, 2019 Aaron M. Ucko <ucko@debian.org>
License: BSD-3
Files: rogue/*
diff --git a/debian/docs b/debian/docs
index 9c446e3..5be1658 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1,7 +1,7 @@
AUTHORS
BUGS
-ChangeLog
ChangeLog.0
+NEWS
README.non-free
SECURITY
THANKS
diff --git a/debian/rules b/debian/rules
index 58265b5..1563e32 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,9 +4,7 @@ DEB_DESTDIR = $(CURDIR)/debian/$(pkg)
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
-CFLAGS := $(shell dpkg-buildflags --get CFLAGS) \
- $(shell dpkg-buildflags --get CPPFLAGS)
-LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
+include /usr/share/dpkg/buildflags.mk
%:
dh $@
@@ -15,7 +13,7 @@ override_dh_auto_clean:
dh_auto_clean -- -f GNUmakefile distclean
override_dh_auto_configure:
- bsd_games_cfg_other_cflags="$(CFLAGS)" \
+ bsd_games_cfg_other_cflags="$(CFLAGS) $(CPPFLAGS)" \
bsd_games_cfg_other_ldflags="$(LDFLAGS)" \
./configure
@@ -28,7 +26,7 @@ override_dh_auto_install:
cp rogue/CHANGES $(DEB_DESTDIR)/usr/share/doc/$(pkg)/CHANGES.rogue
override_dh_installchangelogs:
- dh_installchangelogs -k NEWS
+ dh_installchangelogs -k ChangeLog
override_dh_fixperms:
dh_fixperms -X/usr/games/rogue