summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--LAsort.c21
-rw-r--r--ONE2LA.c2
-rw-r--r--QV.c2
-rw-r--r--align.c4
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/typos.patch24
6 files changed, 51 insertions, 9 deletions
diff --git a/LAsort.c b/LAsort.c
index 2a7e11f..52014d0 100644
--- a/LAsort.c
+++ b/LAsort.c
@@ -241,7 +241,7 @@ int main(int argc, char *argv[])
for (i = 1; i < argc; i++)
{ int64 *perm;
FILE *input, *foutput;
- int64 novl, sov;
+ int64 novl, sov, bovl;
Block_Looper *parse;
parse = Parse_Block_LAS_Arg(argv[i]);
@@ -273,9 +273,9 @@ int main(int argc, char *argv[])
if (VERBOSE)
{ printf(" %s: ",root);
Print_Number(novl,0,stdout);
- printf(" records ");
+ printf(" records, ");
Print_Number(size-novl*ovlsize,0,stdout);
- printf(" trace bytes\n");
+ printf(" trace bytes");
fflush(stdout);
}
@@ -361,6 +361,7 @@ int main(int argc, char *argv[])
y.aread = ((Overlap *) (iblock+perm[0]))->aread+1;
x = &y;
+ bovl = novl;
fptr = fblock;
ftop = fblock + osize;
for (j = 0; j < sov; j++)
@@ -375,9 +376,7 @@ int main(int argc, char *argv[])
fptr = fblock;
}
if (equal)
- { fptr += (ovlsize + tsize);
- novl -= 1;
- }
+ novl -= 1;
else
{ memmove(fptr,((char *) w)+ptrsize,ovlsize);
fptr += ovlsize;
@@ -399,6 +398,16 @@ int main(int argc, char *argv[])
if (fwrite(&novl,sizeof(int64),1,foutput) != 1)
SYSTEM_WRITE_ERROR
+ if (VERBOSE)
+ { if (bovl == novl)
+ fprintf(stdout,"\n");
+ else
+ { fprintf(stdout,", ");
+ Print_Number(bovl-novl,0,stdout);
+ fprintf(stdout," duplicates removed\n");
+ }
+ }
+
free(perm);
fclose(foutput);
}
diff --git a/ONE2LA.c b/ONE2LA.c
index 77b4bae..4581433 100644
--- a/ONE2LA.c
+++ b/ONE2LA.c
@@ -152,7 +152,7 @@ int main(int argc, char *argv[])
{ t = oneReadLine(file1);
if (t == 0)
- { fprintf(stderr,"ONE2LA: Pile object not followed by sufficient auxilliary lines\n");
+ { fprintf(stderr,"ONE2LA: Pile object not followed by sufficient auxiliary lines\n");
exit (1);
}
if (has[t] > 0 && t != 'T' && t != 'Q')
diff --git a/QV.c b/QV.c
index d7d7263..723afbf 100644
--- a/QV.c
+++ b/QV.c
@@ -1319,7 +1319,7 @@ error:
EXIT(NULL);
}
- // Free all the auxilliary storage associated with the encoding argument
+ // Free all the auxiliary storage associated with the encoding argument
void Free_QVcoding(QVcoding *coding)
{ if (coding->subChar >= 0)
diff --git a/align.c b/align.c
index c323ce2..4f7ef1d 100644
--- a/align.c
+++ b/align.c
@@ -5155,6 +5155,8 @@ int Compute_Trace_PTS(Alignment *align, Work_Data *ework, int trace_spacing, int
}
if (tlen <= 1)
nmax = N;
+ if (dmax & 0x1)
+ dmax += 1;
s = (dmax+3)*2*((trace_spacing+nmax+3)*sizeof(int) + sizeof(int *));
@@ -5265,6 +5267,8 @@ int Compute_Trace_MID(Alignment *align, Work_Data *ework, int trace_spacing, int
}
if (tlen <= 1)
nmax = N;
+ if (dmax & 0x1)
+ dmax += 1;
s = (dmax+3)*4*((trace_spacing+nmax+3)*sizeof(int) + sizeof(int *));
diff --git a/debian/changelog b/debian/changelog
index 84a5049..effa539 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+daligner (1.0+git20230620.f9a35a8-1) unstable; urgency=medium
+
+ * New upstream version 1.0+git20230620.f9a35a8
+ * typos.patch: fix "auxiliary" typos.
+
+ -- Étienne Mollier <emollier@debian.org> Thu, 20 Jul 2023 11:10:34 +0200
+
daligner (1.0+git20221215.bd26967-1) unstable; urgency=medium
* New upstream version
diff --git a/debian/patches/typos.patch b/debian/patches/typos.patch
index 93fc1b7..5549025 100644
--- a/debian/patches/typos.patch
+++ b/debian/patches/typos.patch
@@ -1,7 +1,7 @@
Description: fix a couple of typos caught by lintian.
Author: Étienne Mollier <emollier@debian.org>
Forwarded: no
-Last-Update: 2022-08-03
+Last-Update: 2023-07-20
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- daligner.orig/DB.c
@@ -57,3 +57,25 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
break;
case 'H':
ARG_POSITIVE(HGAP_MIN,"HGAP threshold (in bp.s)")
+--- daligner.orig/ONE2LA.c
++++ daligner/ONE2LA.c
+@@ -152,7 +152,7 @@
+ { t = oneReadLine(file1);
+
+ if (t == 0)
+- { fprintf(stderr,"ONE2LA: Pile object not followed by sufficient auxilliary lines\n");
++ { fprintf(stderr,"ONE2LA: Pile object not followed by sufficient auxiliary lines\n");
+ exit (1);
+ }
+ if (has[t] > 0 && t != 'T' && t != 'Q')
+--- daligner.orig/QV.c
++++ daligner/QV.c
+@@ -1319,7 +1319,7 @@
+ EXIT(NULL);
+ }
+
+- // Free all the auxilliary storage associated with the encoding argument
++ // Free all the auxiliary storage associated with the encoding argument
+
+ void Free_QVcoding(QVcoding *coding)
+ { if (coding->subChar >= 0)