summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ONElib.c2
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/fix-missing-include.patch20
-rw-r--r--debian/patches/series1
4 files changed, 29 insertions, 0 deletions
diff --git a/ONElib.c b/ONElib.c
index a47e3bd..3203992 100644
--- a/ONElib.c
+++ b/ONElib.c
@@ -16,8 +16,10 @@
*
****************************************************************************************/
+#define _GNU_SOURCE
#include <sys/errno.h>
#include <sys/types.h>
+#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <sys/resource.h>
diff --git a/debian/changelog b/debian/changelog
index 34baae5..d11daa8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+daligner (1.0+git20240119.335105d-2) unstable; urgency=medium
+
+ * fix-missing-include.patch: new: fix ftbfs with dpkg. (Closes: #1066534)
+
+ -- Étienne Mollier <emollier@debian.org> Wed, 13 Mar 2024 21:38:57 +0100
+
daligner (1.0+git20240119.335105d-1) unstable; urgency=medium
* New upstream version
diff --git a/debian/patches/fix-missing-include.patch b/debian/patches/fix-missing-include.patch
new file mode 100644
index 0000000..7aaf861
--- /dev/null
+++ b/debian/patches/fix-missing-include.patch
@@ -0,0 +1,20 @@
+Description: fix missing include.
+Author: Étienne Mollier <emollier@debian.org>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1066534
+Forwarded: https://github.com/thegenemyers/DALIGNER/pull/96
+Last-Update: 2024-03-13
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- daligner.orig/ONElib.c
++++ daligner/ONElib.c
+@@ -16,8 +16,10 @@
+ *
+ ****************************************************************************************/
+
++#define _GNU_SOURCE
+ #include <sys/errno.h>
+ #include <sys/types.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/resource.h>
diff --git a/debian/patches/series b/debian/patches/series
index de87cdb..a9ce9fd 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@ lddflags.patch
destdir-install.patch
cross.patch
cppflags.patch
+fix-missing-include.patch