summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOsamu Aoki <osamu@debian.org>2023-10-30 00:10:49 +0900
committerOsamu Aoki <osamu@debian.org>2023-10-30 00:10:49 +0900
commit048907e78b50ce08da5b278e724d8a5aba187ff5 (patch)
tree0999b20cfddbbd677cd440a4d373293fa6045420
parent8c5ac765f54e0b0c2cb0910cb8ff838739558fe1 (diff)
Commit Debian 3.0 (quilt) metadatadebian/4.4.0-3archive/debian/4.4.0-3
[dgit (10.7+deb12u2) quilt-fixup]
-rw-r--r--debian/patches/debian-changes11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
index e5c80a1..46dda32 100644
--- a/debian/patches/debian-changes
+++ b/debian/patches/debian-changes
@@ -25,6 +25,17 @@ Please see https://salsa.debian.org/debian/debmake
__debian_compat__ = "13" # debian/control Build-Depends: debhelper-compat (= 13)
__programname__ = "debmake"
__version__ = "4.4.0"
+--- debmake-4.4.0.orig/src/debmake/analyze.py
++++ debmake-4.4.0/src/debmake/analyze.py
+@@ -436,7 +436,7 @@ def analyze(para):
+ elif os.path.isfile("package.json"):
+ para["build_type"] = "nodejs"
+ para["dh_with"].update({"nodejs"})
+- para["build_depends"].update({"pkg-js-tools"})
++ para["build_depends"].update({"dh-nodejs"})
+ # Java
+ elif os.path.isfile("build.xml"):
+ para["build_type"] = "Java ant"
--- debmake-4.4.0.orig/src/debmake/debian.py
+++ debmake-4.4.0/src/debmake/debian.py
@@ -200,16 +200,12 @@ def debian(para):