summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.org5
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/auto-1.3.1+repack-3-6ebaf87d7442f468b1c979ada7c3cb845fde9b5e-156668970050
-rw-r--r--debian/patches/series1
4 files changed, 62 insertions, 1 deletions
diff --git a/README.org b/README.org
index b7a7f98..b777b44 100644
--- a/README.org
+++ b/README.org
@@ -1,5 +1,5 @@
#+OPTIONS: toc:nil num:nil
-#+TITLE: The Bug Hunter
+#+TITLE: [[file:hunter.png]] The Bug Hunter [[https://travis-ci.org/Malabarba/elisp-bug-hunter][file:https://travis-ci.org/Malabarba/elisp-bug-hunter.svg?branch=master]]
/Automatically debug and bisect your init (.emacs) file!/
@@ -7,6 +7,8 @@ The Bug Hunter is an Emacs library that finds the source of an error
or unexpected behavior inside an elisp configuration file (typically
~init.el~ or ~.emacs~).
+[[file:hunter-screencast.gif]]
+
* Usage Examples
** Automated error hunting
@@ -48,6 +50,7 @@ M-x bug-hunter-init-file RET a (featurep 'cl) RET
*That’s it!* You’ll be given a nice buffer reporting the results:
+[[file:cl-example.png]]
- Are you getting obscure errors when trying to open /“.tex”/ files?
- Don’t despair! Just use ~(and (find-file "dummy.tex") nil)~ as the assertion.
- Did ~ox-html~ stop working due to some arcane misconfiguration?
diff --git a/debian/changelog b/debian/changelog
index 11d2e82..4d4ae87 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+elisp-bug-hunter (1.3.1+repack-3) unstable; urgency=medium
+
+ * Team upload.
+ * Rebuild with current dh-elpa
+
+ -- David Bremner <bremner@debian.org> Sat, 24 Aug 2019 20:34:58 -0300
+
elisp-bug-hunter (1.3.1+repack-2) unstable; urgency=medium
* Team upload.
diff --git a/debian/patches/auto-1.3.1+repack-3-6ebaf87d7442f468b1c979ada7c3cb845fde9b5e-1566689700 b/debian/patches/auto-1.3.1+repack-3-6ebaf87d7442f468b1c979ada7c3cb845fde9b5e-1566689700
new file mode 100644
index 0000000..03c1c58
--- /dev/null
+++ b/debian/patches/auto-1.3.1+repack-3-6ebaf87d7442f468b1c979ada7c3cb845fde9b5e-1566689700
@@ -0,0 +1,50 @@
+From: David Bremner <bremner@debian.org>
+Subject: Automatically generated patch (1.3.1+repack-3)
+
+Last (up to) 3 git changes, FYI:
+
+commit 6ebaf87d7442f468b1c979ada7c3cb845fde9b5e
+Author: David Bremner <david@tethera.net>
+Date: Sat Aug 24 20:34:58 2019 -0300
+
+ changelog for rebuild with current dh-elpa
+
+commit 5070c19f249a6d07be10bdc6a2deb7187df1324f
+Author: David Bremner <david@tethera.net>
+Date: Fri Jun 1 20:56:10 2018 -0300
+
+ changelog for byte compilation rebuild
+
+commit d6c1cc7151942d942b5abed8eaf07f965c529f8d
+Author: Lev Lamberov <dogsleg@debian.org>
+Date: Sat Apr 7 15:13:53 2018 +0500
+
+ Fix Vcs URLs
+---
+
+--- elisp-bug-hunter-1.3.1+repack.orig/README.org
++++ elisp-bug-hunter-1.3.1+repack/README.org
+@@ -1,5 +1,5 @@
+ #+OPTIONS: toc:nil num:nil
+-#+TITLE: The Bug Hunter
++#+TITLE: [[file:hunter.png]] The Bug Hunter [[https://travis-ci.org/Malabarba/elisp-bug-hunter][file:https://travis-ci.org/Malabarba/elisp-bug-hunter.svg?branch=master]]
+
+ /Automatically debug and bisect your init (.emacs) file!/
+
+@@ -7,6 +7,8 @@ The Bug Hunter is an Emacs library that
+ or unexpected behavior inside an elisp configuration file (typically
+ ~init.el~ or ~.emacs~).
+
++[[file:hunter-screencast.gif]]
++
+ * Usage Examples
+
+ ** Automated error hunting
+@@ -48,6 +50,7 @@ M-x bug-hunter-init-file RET a (featurep
+
+ *That’s it!* You’ll be given a nice buffer reporting the results:
+
++[[file:cl-example.png]]
+ - Are you getting obscure errors when trying to open /“.tex”/ files?
+ - Don’t despair! Just use ~(and (find-file "dummy.tex") nil)~ as the assertion.
+ - Did ~ox-html~ stop working due to some arcane misconfiguration?
diff --git a/debian/patches/series b/debian/patches/series
index db340cf..f24bc40 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-fix-documentation.diff
+auto-1.3.1+repack-3-6ebaf87d7442f468b1c979ada7c3cb845fde9b5e-1566689700