summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac10
-rw-r--r--debian/changelog23
-rw-r--r--debian/compat1
-rw-r--r--debian/control7
-rw-r--r--debian/gmpc-data.install2
-rw-r--r--debian/patches/Don-t-install-remote-man-pages-if-remote-is-disabled.patch25
-rw-r--r--debian/patches/Port-from-obsolete-gnome-doc-utils-to-yelp-tools.patch132
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules13
-rw-r--r--doc/Makefile.am9
-rw-r--r--doc/Mallard/Makefile.am15
-rw-r--r--src/browsers/playlist3-file-browser.c2
-rw-r--r--src/main.c2
-rw-r--r--src/playlist3.c2
14 files changed, 219 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 96ad6a2..8b7c9d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -397,7 +397,13 @@ if test x$enable_shave = xyes; then
SHAVE_INIT([./])
fi
-GNOME_DOC_INIT([0.18.0], [have_gdu=yes], [have_gdu=no])
+AC_ARG_WITH([help],
+ [AS_HELP_STRING],
+ [have_yelp="$withval"],
+ [have_yelp=yes])
+AS_IF([test "x$have_yelp" != xno],
+ [YELP_HELP_INIT])
+AM_CONDITIONAL([HAVE_YELP], [test x"$have_yelp" = xyes])
AC_OUTPUT([
shave
@@ -538,7 +544,7 @@ if test "x$unique" = "xtrue"; then
else
echo "Use unique library: disabled"
fi
-if test "x$have_gdu" = "xyes"; then
+if test "x$have_yelp" = "xyes"; then
echo "Use Gnome Documentation: enabled"
else
echo "Use Gnome Documentation: disabled"
diff --git a/debian/changelog b/debian/changelog
index d98c97a..70590b6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,20 @@
+gmpc (11.8.16-17) unstable; urgency=medium
+
+ * d/p/Port-from-obsolete-gnome-doc-utils-to-yelp-tools.patch,
+ d/control:
+ Switch from gnome-doc-utils to yelp-tools (Closes: #829853, #947528)
+ * d/rules: Remove remnants of gmpc-dbg
+ * Only build help if we are building gmpc-data
+ * Remove unused build-dependency on libglade.
+ gmpc has used GtkBuilder instead since 11.8.16.
+ * d/p/Don-t-install-remote-man-pages-if-remote-is-disabled.patch:
+ Don't install man pages for executables that we disabled
+ * Move to debhelper-compat 12
+ * Standards-Version: 4.5.0 (no changes required)
+ * d/changelog: Trim trailing whitespace
+
+ -- Simon McVittie <smcv@debian.org> Mon, 10 Feb 2020 15:22:06 +0000
+
gmpc (11.8.16-16) unstable; urgency=medium
* d/salsa-ci.yml: Request standard CI on salsa.debian.org
@@ -190,11 +207,11 @@ gmpc (0.20.0-2) unstable; urgency=low
- Switch to 3.0 (quilt) source format
- Add watchfile
- Bum Standards-Version to 3.9.2 (no changes)
- - Remove build-dep on quilt
+ - Remove build-dep on quilt
* Build changes:
- Explicitly add libraries to fix FTBFS with new toolchain
(Closes: #554541, thanks to Mahyuddin Susanto)
- - Add -Wl,--as-needed to LDFLAGS
+ - Add -Wl,--as-needed to LDFLAGS
- Code is now generated from vala at build time
* debian/control:
- Replace "Conflicts: gmpc-plugins" with "Breaks:"
@@ -330,7 +347,7 @@ gmpc (0.15.5.0-2.1) unstable; urgency=low
* Add patch to src/main.c to search for plugins in LIB_PATH; set LIB_PATH
in debian/rules (closes: #459405)
* debian/menu: fix section
- * debian/control:
+ * debian/control:
- fix build-dep on libmpd-dev
- Source-Version -> binary:Version
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index f599e28..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-10
diff --git a/debian/control b/debian/control
index bccbe26..539c860 100644
--- a/debian/control
+++ b/debian/control
@@ -5,13 +5,11 @@ Maintainer: mpd maintainers <pkg-mpd-maintainers@lists.alioth.debian.org>
Uploaders: Antoine Beaupré <anarcat@debian.org>,
Etienne Millon <me@emillon.org>,
Simon McVittie <smcv@debian.org>
-Build-Depends: debhelper (>= 10~),
- gnome-doc-utils,
+Build-Depends: debhelper-compat (= 12),
gob2,
intltool,
libappindicator-dev,
libcurl4-gnutls-dev,
- libglade2-dev,
libglib2.0-dev,
libgtk2.0-dev,
libmpd-dev,
@@ -19,8 +17,9 @@ Build-Depends: debhelper (>= 10~),
libsqlite3-dev,
valac,
zlib1g-dev
+Build-Depends-Indep: yelp-tools
Rules-Requires-Root: no
-Standards-Version: 4.4.1
+Standards-Version: 4.5.0
Homepage: https://gmpclient.org/
Vcs-Git: https://salsa.debian.org/mpd-team/gmpc.git
Vcs-Browser: https://salsa.debian.org/mpd-team/gmpc
diff --git a/debian/gmpc-data.install b/debian/gmpc-data.install
index d24972d..148be10 100644
--- a/debian/gmpc-data.install
+++ b/debian/gmpc-data.install
@@ -1,4 +1,4 @@
usr/share/gmpc/*
-usr/share/gnome/help/gmpc/*
+usr/share/help
usr/share/icons/*
usr/share/locale/*
diff --git a/debian/patches/Don-t-install-remote-man-pages-if-remote-is-disabled.patch b/debian/patches/Don-t-install-remote-man-pages-if-remote-is-disabled.patch
new file mode 100644
index 0000000..61b8724
--- /dev/null
+++ b/debian/patches/Don-t-install-remote-man-pages-if-remote-is-disabled.patch
@@ -0,0 +1,25 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Mon, 10 Feb 2020 14:46:07 +0000
+Subject: Don't install remote man pages if remote is disabled
+
+Signed-off-by: Simon McVittie <smcv@debian.org>
+Forwarded: no
+---
+ doc/Makefile.am | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index a9b10a7..f61d010 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,4 +1,9 @@
+-man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
++man_MANS = gmpc.1
++
++if HAVE_UNIQUE
++man_MANS += gmpc-remote.1 gmpc-remote-stream.1
++endif
++
+ EXTRA_DIST = $(man_MANS)
+
+ if HAVE_YELP
diff --git a/debian/patches/Port-from-obsolete-gnome-doc-utils-to-yelp-tools.patch b/debian/patches/Port-from-obsolete-gnome-doc-utils-to-yelp-tools.patch
new file mode 100644
index 0000000..2d4a3ab
--- /dev/null
+++ b/debian/patches/Port-from-obsolete-gnome-doc-utils-to-yelp-tools.patch
@@ -0,0 +1,132 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Mon, 10 Feb 2020 14:11:46 +0000
+Subject: Port from obsolete gnome-doc-utils to yelp-tools
+
+Signed-off-by: Simon McVittie <smcv@debian.org>
+Bug-Debian: https://bugs.debian.org/947528
+Forwarded: no
+---
+ configure.ac | 10 ++++++++--
+ doc/Makefile.am | 2 ++
+ doc/Mallard/Makefile.am | 15 ++++++++-------
+ src/browsers/playlist3-file-browser.c | 2 +-
+ src/main.c | 2 +-
+ src/playlist3.c | 2 +-
+ 6 files changed, 21 insertions(+), 12 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 96ad6a2..8b7c9d1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -397,7 +397,13 @@ if test x$enable_shave = xyes; then
+ SHAVE_INIT([./])
+ fi
+
+-GNOME_DOC_INIT([0.18.0], [have_gdu=yes], [have_gdu=no])
++AC_ARG_WITH([help],
++ [AS_HELP_STRING],
++ [have_yelp="$withval"],
++ [have_yelp=yes])
++AS_IF([test "x$have_yelp" != xno],
++ [YELP_HELP_INIT])
++AM_CONDITIONAL([HAVE_YELP], [test x"$have_yelp" = xyes])
+
+ AC_OUTPUT([
+ shave
+@@ -538,7 +544,7 @@ if test "x$unique" = "xtrue"; then
+ else
+ echo "Use unique library: disabled"
+ fi
+-if test "x$have_gdu" = "xyes"; then
++if test "x$have_yelp" = "xyes"; then
+ echo "Use Gnome Documentation: enabled"
+ else
+ echo "Use Gnome Documentation: disabled"
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 1deb85f..a9b10a7 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,7 +1,9 @@
+ man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
+ EXTRA_DIST = $(man_MANS)
+
++if HAVE_YELP
+ SUBDIRS=Mallard
++endif
+
+ .PHONY: doc
+ doc: Manual.txt
+diff --git a/doc/Mallard/Makefile.am b/doc/Mallard/Makefile.am
+index 10bfdc9..f6939f9 100644
+--- a/doc/Mallard/Makefile.am
++++ b/doc/Mallard/Makefile.am
+@@ -1,9 +1,10 @@
+-include ../../gnome-doc-utils.make
+-DOC_ID = @PACKAGE@
+-DOC_INCLUDES = legal.xml
+-DOC_LINGUAS=
++@YELP_HELP_RULES@
+
+-DOC_PAGES = \
++HELP_ID = @PACKAGE@
++HELP_EXTRA = legal.xml
++HELP_LINGUAS=
++
++HELP_FILES = \
+ AboutThisDocument.page\
+ BrowserArtistBrowser.page\
+ BrowserDatabase.page\
+@@ -34,7 +35,7 @@ DOC_PAGES = \
+ ProblemSolving.page\
+ TipsAndTricks.page
+
+-DOC_FIGURES=\
++HELP_MEDIA=\
+ Images/browser-pane-double.png\
+ Images/browser-pane-single.png\
+ Images/database-columns.png\
+@@ -108,5 +109,5 @@ create-xhtml-pages:
+ @mkdir html;\
+ for a in $(DOC_PAGES);\
+ do\
+- bash gnome-doc-tool xhtml --copy-graphics --css-file="style.css" "C/$$a" -o html/;\
++ yelp-build xhtml "C/$$a" -o html/;\
+ done
+diff --git a/src/browsers/playlist3-file-browser.c b/src/browsers/playlist3-file-browser.c
+index 8518566..3bd6ca8 100644
+--- a/src/browsers/playlist3-file-browser.c
++++ b/src/browsers/playlist3-file-browser.c
+@@ -157,7 +157,7 @@ static void playtime_changed(GmpcMpdDataModel * model, gulong playtime)
+ }
+ static void pl3_file_support_help_button_clicked(GObject *a)
+ {
+- open_uri("ghelp:gmpc#ProblemSolving");
++ open_uri("help:gmpc#ProblemSolving");
+ }
+ static void pl3_file_browser_init(void)
+ {
+diff --git a/src/main.c b/src/main.c
+index 0c8f8e3..6b88742 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -881,7 +881,7 @@ void send_password(void)
+
+ static void playlist_support_help_button_clicked(GObject *a)
+ {
+- open_uri("ghelp:gmpc#ProblemSolving");
++ open_uri("help:gmpc#ProblemSolving");
+
+ }
+
+diff --git a/src/playlist3.c b/src/playlist3.c
+index 3dac409..c0cb272 100644
+--- a/src/playlist3.c
++++ b/src/playlist3.c
+@@ -2504,6 +2504,6 @@ void open_local_file(void)
+ void show_user_manual(void);
+ void show_user_manual(void)
+ {
+- open_uri("ghelp:gmpc");
++ open_uri("help:gmpc");
+ }
+ /* vim: set noexpandtab ts=4 sw=4 sts=4 tw=80: */
diff --git a/debian/patches/series b/debian/patches/series
index 73052ad..eff1751 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -17,3 +17,5 @@
Fix-build-failure-with-Vala-0.38.patch
Fix-build-with-Vala-0.44.patch
Move-out-parameters-to-last-position.patch
+Port-from-obsolete-gnome-doc-utils-to-yelp-tools.patch
+Don-t-install-remote-man-pages-if-remote-is-disabled.patch
diff --git a/debian/rules b/debian/rules
index 24dd15d..a2a4a64 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,14 @@
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+binaries := $(shell dh_listpackages)
+
+ifneq ($(filter gmpc-data,$(binaries)),)
+configure_flags += --with-help
+else
+configure_flags += --without-help
+endif
+
%:
dh $@
@@ -10,18 +18,15 @@ override_dh_auto_configure:
dh_auto_configure \
-- \
--disable-unique \
+ $(configure_flags) \
${NULL}
[ ! -d .pc ] || find .pc -type f -name '*.c' -exec echo '{}' >> po/POTFILES.skip \;
override_dh_installdocs:
dh_installdocs
- make -C doc/Mallard DESTDIR=debian/tmp/usr install
mkdir -p debian/gmpc-dev/usr/share/doc
rm -rf debian/gmpc-dev/usr/share/doc/gmpc-dev
ln -sf gmpc debian/gmpc-dev/usr/share/doc/gmpc-dev
- mkdir -p debian/gmpc-dbg/usr/share/doc
- rm -rf debian/gmpc-dbg/usr/share/doc/gmpc-dbg
- ln -sf gmpc debian/gmpc-dbg/usr/share/doc/gmpc-dbg
override_dh_clean:
dh_clean
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 1deb85f..f61d010 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,7 +1,14 @@
-man_MANS = gmpc.1 gmpc-remote.1 gmpc-remote-stream.1
+man_MANS = gmpc.1
+
+if HAVE_UNIQUE
+man_MANS += gmpc-remote.1 gmpc-remote-stream.1
+endif
+
EXTRA_DIST = $(man_MANS)
+if HAVE_YELP
SUBDIRS=Mallard
+endif
.PHONY: doc
doc: Manual.txt
diff --git a/doc/Mallard/Makefile.am b/doc/Mallard/Makefile.am
index 10bfdc9..f6939f9 100644
--- a/doc/Mallard/Makefile.am
+++ b/doc/Mallard/Makefile.am
@@ -1,9 +1,10 @@
-include ../../gnome-doc-utils.make
-DOC_ID = @PACKAGE@
-DOC_INCLUDES = legal.xml
-DOC_LINGUAS=
+@YELP_HELP_RULES@
-DOC_PAGES = \
+HELP_ID = @PACKAGE@
+HELP_EXTRA = legal.xml
+HELP_LINGUAS=
+
+HELP_FILES = \
AboutThisDocument.page\
BrowserArtistBrowser.page\
BrowserDatabase.page\
@@ -34,7 +35,7 @@ DOC_PAGES = \
ProblemSolving.page\
TipsAndTricks.page
-DOC_FIGURES=\
+HELP_MEDIA=\
Images/browser-pane-double.png\
Images/browser-pane-single.png\
Images/database-columns.png\
@@ -108,5 +109,5 @@ create-xhtml-pages:
@mkdir html;\
for a in $(DOC_PAGES);\
do\
- bash gnome-doc-tool xhtml --copy-graphics --css-file="style.css" "C/$$a" -o html/;\
+ yelp-build xhtml "C/$$a" -o html/;\
done
diff --git a/src/browsers/playlist3-file-browser.c b/src/browsers/playlist3-file-browser.c
index 8518566..3bd6ca8 100644
--- a/src/browsers/playlist3-file-browser.c
+++ b/src/browsers/playlist3-file-browser.c
@@ -157,7 +157,7 @@ static void playtime_changed(GmpcMpdDataModel * model, gulong playtime)
}
static void pl3_file_support_help_button_clicked(GObject *a)
{
- open_uri("ghelp:gmpc#ProblemSolving");
+ open_uri("help:gmpc#ProblemSolving");
}
static void pl3_file_browser_init(void)
{
diff --git a/src/main.c b/src/main.c
index 0c8f8e3..6b88742 100644
--- a/src/main.c
+++ b/src/main.c
@@ -881,7 +881,7 @@ void send_password(void)
static void playlist_support_help_button_clicked(GObject *a)
{
- open_uri("ghelp:gmpc#ProblemSolving");
+ open_uri("help:gmpc#ProblemSolving");
}
diff --git a/src/playlist3.c b/src/playlist3.c
index 3dac409..c0cb272 100644
--- a/src/playlist3.c
+++ b/src/playlist3.c
@@ -2504,6 +2504,6 @@ void open_local_file(void)
void show_user_manual(void);
void show_user_manual(void)
{
- open_uri("ghelp:gmpc");
+ open_uri("help:gmpc");
}
/* vim: set noexpandtab ts=4 sw=4 sts=4 tw=80: */