summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac30
-rw-r--r--debian/changelog19
-rw-r--r--debian/control8
-rw-r--r--debian/gmpc-dev.maintscript1
-rw-r--r--debian/patches/Check-for-ayatana-appindicator-instead-of-deprecated-liba.patch79
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules6
-rw-r--r--src/tray-icon2.c2
8 files changed, 120 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 8b7c9d1..d52815e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -363,27 +363,27 @@ fi
APPINDICATOR_REQUIRED=0.3
-AC_ARG_ENABLE(appindicator,
- AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for application indicators ]),
- [enable_appindicator=$enableval],
- [enable_appindicator="auto"])
-
-if test x$enable_appindicator = xauto ; then
- PKG_CHECK_EXISTS([appindicator-0.1 >= $APPINDICATOR_REQUIRED],
- enable_appindicator="yes",
- enable_appindicator="no")
+AC_ARG_ENABLE(ayatana-appindicator,
+ AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for ayatana application indicators ]),
+ [enable_ayatana_appindicator=$enableval],
+ [enable_ayatana_appindicator="auto"])
+
+if test x$enable_ayatana_appindicator = xauto ; then
+ PKG_CHECK_EXISTS([ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED],
+ enable_ayatana_appindicator="yes",
+ enable_ayatana_appindicator="no")
fi
-if test x$enable_appindicator = xyes ; then
- PKG_CHECK_EXISTS([appindicator-0.1 >= $APPINDICATOR_REQUIRED],,
- AC_MSG_ERROR([appindicator-0.1 is not installed]))
+if test x$enable_ayatana_appindicator = xyes ; then
+ PKG_CHECK_EXISTS([ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED],,
+ AC_MSG_ERROR([ayatana-appindicator-0.1 is not installed]))
PKG_CHECK_MODULES(APP_INDICATOR,
- appindicator-0.1 >= $APPINDICATOR_REQUIRED)
+ ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED)
AC_SUBST(APP_INDICATOR_CFLAGS)
AC_SUBST(APP_INDICATOR_LIBS)
AC_DEFINE(HAVE_APP_INDICATOR, 1, [Have AppIndicator])
fi
-AM_CONDITIONAL(HAVE_APP_INDICATOR, test x"$enable_appindicator" = xyes)
+AM_CONDITIONAL(HAVE_APP_INDICATOR, test x"$enable_ayatana_appindicator" = xyes)
AC_ARG_ENABLE([shave],
[ --disable-shave Use shave output cleaner when building.],
@@ -524,7 +524,7 @@ if test x${enable_mmkeys} = xyes; then
else
echo "Multimedia keys support is: disabled"
fi
-if test x"$enable_appindicator" = xyes; then
+if test x"$enable_ayatana_appindicator" = xyes; then
echo "AppIndicator Support is: enabled"
else
echo "AppIndicator Support is: disabled"
diff --git a/debian/changelog b/debian/changelog
index 70590b6..d0a0333 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,22 @@
+gmpc (11.8.16-18) unstable; urgency=medium
+
+ [ Simon McVittie ]
+ * Switch from libappindicator to ayatana-appindicator.
+ Thanks to Kentaro Hayashi (Closes: #956768)
+ * Remove unused libcurl build-dependency.
+ libsoup is now used instead.
+ * Drop Depends on gmpc by gmpc-dev.
+ gmpc-dev only contains header files, and there is no shared library;
+ the gmpc executable is unnecessary for building plugins.
+ For Policy compliance, this requires migrating its /usr/share/doc
+ directory from symlink to directory.
+
+ [ Helmut Grohne ]
+ * Mark gmpc-dev Multi-Arch: same
+ * Mark gmpc-data Multi-Arch: foreign (Closes: #893034)
+
+ -- Simon McVittie <smcv@debian.org> Wed, 19 Aug 2020 09:26:08 +0100
+
gmpc (11.8.16-17) unstable; urgency=medium
* d/p/Port-from-obsolete-gnome-doc-utils-to-yelp-tools.patch,
diff --git a/debian/control b/debian/control
index 539c860..6e9de87 100644
--- a/debian/control
+++ b/debian/control
@@ -8,8 +8,7 @@ Uploaders: Antoine Beaupré <anarcat@debian.org>,
Build-Depends: debhelper-compat (= 12),
gob2,
intltool,
- libappindicator-dev,
- libcurl4-gnutls-dev,
+ libayatana-appindicator-dev,
libglib2.0-dev,
libgtk2.0-dev,
libmpd-dev,
@@ -43,8 +42,8 @@ Description: GNOME Music Player Client (graphical interface to MPD)
Package: gmpc-dev
Architecture: any
-Depends: gmpc (= ${binary:Version}),
- libmpd-dev,
+Multi-Arch: same
+Depends: libmpd-dev,
pkg-config,
${misc:Depends}
Description: GNOME Music Player Client (plugin development files)
@@ -62,6 +61,7 @@ Description: GNOME Music Player Client (plugin development files)
Package: gmpc-data
Architecture: all
+Multi-Arch: foreign
Depends: ${misc:Depends}
Recommends: gmpc
Replaces: gmpc (<< 0.20.0-2)
diff --git a/debian/gmpc-dev.maintscript b/debian/gmpc-dev.maintscript
new file mode 100644
index 0000000..6bd2535
--- /dev/null
+++ b/debian/gmpc-dev.maintscript
@@ -0,0 +1 @@
+symlink_to_dir /usr/share/doc/gmpc-dev /usr/share/doc/gmpc 11.8.16-18~ gmpc-dev
diff --git a/debian/patches/Check-for-ayatana-appindicator-instead-of-deprecated-liba.patch b/debian/patches/Check-for-ayatana-appindicator-instead-of-deprecated-liba.patch
new file mode 100644
index 0000000..23f1953
--- /dev/null
+++ b/debian/patches/Check-for-ayatana-appindicator-instead-of-deprecated-liba.patch
@@ -0,0 +1,79 @@
+From: Kentaro Hayashi <hayashi@clear-code.com>
+Date: Wed, 29 Apr 2020 15:14:19 +0900
+Subject: Check for ayatana-appindicator instead of deprecated libappindicator
+
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=956768
+Forwarded: no
+---
+ configure.ac | 30 +++++++++++++++---------------
+ src/tray-icon2.c | 2 +-
+ 2 files changed, 16 insertions(+), 16 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8b7c9d1..d52815e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -363,27 +363,27 @@ fi
+
+ APPINDICATOR_REQUIRED=0.3
+
+-AC_ARG_ENABLE(appindicator,
+- AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for application indicators ]),
+- [enable_appindicator=$enableval],
+- [enable_appindicator="auto"])
+-
+-if test x$enable_appindicator = xauto ; then
+- PKG_CHECK_EXISTS([appindicator-0.1 >= $APPINDICATOR_REQUIRED],
+- enable_appindicator="yes",
+- enable_appindicator="no")
++AC_ARG_ENABLE(ayatana-appindicator,
++ AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for ayatana application indicators ]),
++ [enable_ayatana_appindicator=$enableval],
++ [enable_ayatana_appindicator="auto"])
++
++if test x$enable_ayatana_appindicator = xauto ; then
++ PKG_CHECK_EXISTS([ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED],
++ enable_ayatana_appindicator="yes",
++ enable_ayatana_appindicator="no")
+ fi
+
+-if test x$enable_appindicator = xyes ; then
+- PKG_CHECK_EXISTS([appindicator-0.1 >= $APPINDICATOR_REQUIRED],,
+- AC_MSG_ERROR([appindicator-0.1 is not installed]))
++if test x$enable_ayatana_appindicator = xyes ; then
++ PKG_CHECK_EXISTS([ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED],,
++ AC_MSG_ERROR([ayatana-appindicator-0.1 is not installed]))
+ PKG_CHECK_MODULES(APP_INDICATOR,
+- appindicator-0.1 >= $APPINDICATOR_REQUIRED)
++ ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED)
+ AC_SUBST(APP_INDICATOR_CFLAGS)
+ AC_SUBST(APP_INDICATOR_LIBS)
+ AC_DEFINE(HAVE_APP_INDICATOR, 1, [Have AppIndicator])
+ fi
+-AM_CONDITIONAL(HAVE_APP_INDICATOR, test x"$enable_appindicator" = xyes)
++AM_CONDITIONAL(HAVE_APP_INDICATOR, test x"$enable_ayatana_appindicator" = xyes)
+
+ AC_ARG_ENABLE([shave],
+ [ --disable-shave Use shave output cleaner when building.],
+@@ -524,7 +524,7 @@ if test x${enable_mmkeys} = xyes; then
+ else
+ echo "Multimedia keys support is: disabled"
+ fi
+-if test x"$enable_appindicator" = xyes; then
++if test x"$enable_ayatana_appindicator" = xyes; then
+ echo "AppIndicator Support is: enabled"
+ else
+ echo "AppIndicator Support is: disabled"
+diff --git a/src/tray-icon2.c b/src/tray-icon2.c
+index 561971a..9d7de32 100644
+--- a/src/tray-icon2.c
++++ b/src/tray-icon2.c
+@@ -36,7 +36,7 @@
+ #define TRAY_ICON2_ID "tray-icon2"
+
+ #ifdef HAVE_APP_INDICATOR
+- #include <libappindicator/app-indicator.h>
++ #include <libayatana-appindicator/app-indicator.h>
+ AppIndicator *indicator;
+ #endif
+
diff --git a/debian/patches/series b/debian/patches/series
index eff1751..a1f67a8 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -19,3 +19,4 @@ Fix-build-with-Vala-0.44.patch
Move-out-parameters-to-last-position.patch
Port-from-obsolete-gnome-doc-utils-to-yelp-tools.patch
Don-t-install-remote-man-pages-if-remote-is-disabled.patch
+Check-for-ayatana-appindicator-instead-of-deprecated-liba.patch
diff --git a/debian/rules b/debian/rules
index a2a4a64..32b602b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,12 +22,6 @@ override_dh_auto_configure:
${NULL}
[ ! -d .pc ] || find .pc -type f -name '*.c' -exec echo '{}' >> po/POTFILES.skip \;
-override_dh_installdocs:
- dh_installdocs
- mkdir -p debian/gmpc-dev/usr/share/doc
- rm -rf debian/gmpc-dev/usr/share/doc/gmpc-dev
- ln -sf gmpc debian/gmpc-dev/usr/share/doc/gmpc-dev
-
override_dh_clean:
dh_clean
rm -f intltool-extract intltool-merge intltool-update config.log
diff --git a/src/tray-icon2.c b/src/tray-icon2.c
index 561971a..9d7de32 100644
--- a/src/tray-icon2.c
+++ b/src/tray-icon2.c
@@ -36,7 +36,7 @@
#define TRAY_ICON2_ID "tray-icon2"
#ifdef HAVE_APP_INDICATOR
- #include <libappindicator/app-indicator.h>
+ #include <libayatana-appindicator/app-indicator.h>
AppIndicator *indicator;
#endif