summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--compiler-stdlib/src/dune4
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rw-r--r--shadow-stdlib/src/dune6
4 files changed, 12 insertions, 6 deletions
diff --git a/compiler-stdlib/src/dune b/compiler-stdlib/src/dune
index 317f8e4..f0125b1 100644
--- a/compiler-stdlib/src/dune
+++ b/compiler-stdlib/src/dune
@@ -1,4 +1,4 @@
(library (name caml) (public_name base.caml) (preprocess no_preprocessing))
-(rule (targets caml.ml) (deps (:first_dep ../gen/gen.exe))
- (action (run %{first_dep} -ocaml-where %{ocaml_where} -o %{targets}))) \ No newline at end of file
+(rule (targets caml.ml)
+ (action (run ../gen/gen.exe -ocaml-where %{ocaml_where} -o %{targets})))
diff --git a/debian/changelog b/debian/changelog
index 83567d8..2568505 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+janest-base (0.14.3-1) unstable; urgency=medium
+
+ * New upstream release
+
+ -- Stéphane Glondu <glondu@debian.org> Wed, 02 Mar 2022 07:44:56 +0100
+
janest-base (0.14.2-1) unstable; urgency=medium
[ Stéphane Glondu ]
diff --git a/debian/control b/debian/control
index ca84e46..8278ce7 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Uploaders:
Stéphane Glondu <glondu@debian.org>
Build-Depends:
debhelper-compat (= 13),
- ocaml-nox,
+ ocaml,
ocaml-dune,
libdune-ocaml-dev,
libsexplib0-ocaml-dev (>= 0.14),
diff --git a/shadow-stdlib/src/dune b/shadow-stdlib/src/dune
index 8d3d470..5a8571d 100644
--- a/shadow-stdlib/src/dune
+++ b/shadow-stdlib/src/dune
@@ -2,7 +2,7 @@
(libraries caml) (preprocess no_preprocessing))
(rule (targets shadow_stdlib.mli)
- (deps (:first_dep ../gen/gen.exe) ../../compiler-stdlib/src/caml.cma)
+ (deps ../../compiler-stdlib/src/caml.cma)
(action
- (run %{first_dep} -caml-cmi ../../compiler-stdlib/src/.caml.objs/caml.cmi
- ../../compiler-stdlib/src/.caml.objs/byte/caml.cmi -o %{targets}))) \ No newline at end of file
+ (run ../gen/gen.exe -caml-cmi ../../compiler-stdlib/src/.caml.objs/caml.cmi
+ ../../compiler-stdlib/src/.caml.objs/byte/caml.cmi -o %{targets})))