summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xautosetup/autosetup4
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/changelog9
-rw-r--r--debian/compat2
-rw-r--r--debian/control5
-rw-r--r--debian/patches/0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch27
-rw-r--r--debian/patches/0001-Make-autosetup-accept-disable-enable-silent-rules-by.patch24
-rw-r--r--debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch2
-rw-r--r--debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch2
-rw-r--r--debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch2
-rw-r--r--debian/patches/series2
11 files changed, 49 insertions, 34 deletions
diff --git a/autosetup/autosetup b/autosetup/autosetup
index 0d21e2e..891d834 100755
--- a/autosetup/autosetup
+++ b/autosetup/autosetup
@@ -91,10 +91,12 @@ proc main {argv} {
# Undocumented options
option-checking=1
nopager
- silent-rules
quiet
timing
conf:
+ # Options given by debhelper compat 11+ autoconf:
+ silent-rules
+ runstatedir
}
#parray ::useropts
diff --git a/debian/.git-dpm b/debian/.git-dpm
index eddd468..ab5abe0 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
# see git-dpm(1) from git-dpm package
-99c06db00087a368c0be7b00c71ba9b01d4797ca
-99c06db00087a368c0be7b00c71ba9b01d4797ca
+ef7310242ab5bd0daead9497d3f143f11a6cd2fa
+ef7310242ab5bd0daead9497d3f143f11a6cd2fa
352d61e6661d45100eeea2c960b027be01b7fc37
352d61e6661d45100eeea2c960b027be01b7fc37
jimtcl_0.77+dfsg0.orig.tar.xz
diff --git a/debian/changelog b/debian/changelog
index 591377b..4c0a2fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+jimtcl (0.77+dfsg0-3) unstable; urgency=medium
+
+ * Multi-Arch: mark jimsh as foreign and libjim-dev as same
+ * Bump debhelper compat to 11; update autosetup patch to also accept
+ --runstatedir option
+ * Drop explicit B-D on dpkg-dev
+
+ -- Didier Raboud <odyx@debian.org> Fri, 30 Mar 2018 10:46:04 +0200
+
jimtcl (0.77+dfsg0-2) unstable; urgency=medium
* Cleanup d/control thanks to `cme update dpkg-control`
diff --git a/debian/compat b/debian/compat
index f599e28..b4de394 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-10
+11
diff --git a/debian/control b/debian/control
index 5858f85..19b4d3b 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,7 @@ Source: jimtcl
Maintainer: Didier Raboud <odyx@debian.org>
Section: devel
Priority: optional
-Build-Depends: debhelper (>= 10.2.5~),
- dpkg-dev,
+Build-Depends: debhelper (>= 11~),
asciidoc
Standards-Version: 4.1.3
Vcs-Browser: https://salsa.debian.org/debian/jimtcl
@@ -12,6 +11,7 @@ Homepage: http://jim.tcl.tk/
Package: jimsh
Architecture: any
+Multi-Arch: foreign
Depends: ${shlibs:Depends},
${misc:Depends}
Description: small-footprint implementation of Tcl named Jim
@@ -43,6 +43,7 @@ Description: small-footprint implementation of Tcl - shared library
Package: libjim-dev
Architecture: any
+Multi-Arch: same
Section: libdevel
Depends: libjim0.77 (= ${binary:Version}),
${misc:Depends}
diff --git a/debian/patches/0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch b/debian/patches/0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch
new file mode 100644
index 0000000..ab0f0d1
--- /dev/null
+++ b/debian/patches/0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch
@@ -0,0 +1,27 @@
+From d81f26e30e0923fd9318c569f6eed324f81ede42 Mon Sep 17 00:00:00 2001
+From: Didier Raboud <odyx@debian.org>
+Date: Sun, 27 Aug 2017 17:19:02 +0200
+Subject: Let autosetup accept silent-rules and runstatedir options
+
+These are given by debhelper's dh_auto_configure in compat 11+
+
+Origin: vendor
+Last-Update: 2018-03-30
+---
+ autosetup/autosetup | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/autosetup/autosetup b/autosetup/autosetup
+index 84886c2..891d834 100755
+--- a/autosetup/autosetup
++++ b/autosetup/autosetup
+@@ -94,6 +94,9 @@ proc main {argv} {
+ quiet
+ timing
+ conf:
++ # Options given by debhelper compat 11+ autoconf:
++ silent-rules
++ runstatedir
+ }
+
+ #parray ::useropts
diff --git a/debian/patches/0001-Make-autosetup-accept-disable-enable-silent-rules-by.patch b/debian/patches/0001-Make-autosetup-accept-disable-enable-silent-rules-by.patch
deleted file mode 100644
index 63f3cdb..0000000
--- a/debian/patches/0001-Make-autosetup-accept-disable-enable-silent-rules-by.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From dc16c6f7cd916732f549d409938433c7be5908c1 Mon Sep 17 00:00:00 2001
-From: Didier Raboud <odyx@debian.org>
-Date: Sun, 27 Aug 2017 17:19:02 +0200
-Subject: Make autosetup accept --{disable,enable}-silent-rules by default,
-
- as this is given by debhelper's dh_auto_configure
-Origin: vendor
-Last-Update: 2015-05-26
----
- autosetup/autosetup | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/autosetup/autosetup b/autosetup/autosetup
-index 84886c2..0d21e2e 100755
---- a/autosetup/autosetup
-+++ b/autosetup/autosetup
-@@ -91,6 +91,7 @@ proc main {argv} {
- # Undocumented options
- option-checking=1
- nopager
-+ silent-rules
- quiet
- timing
- conf:
diff --git a/debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch b/debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch
index 3df23f1..d9a4646 100644
--- a/debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch
+++ b/debian/patches/0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch
@@ -1,4 +1,4 @@
-From ae080670e626e1c0c1050816db179884ded558a6 Mon Sep 17 00:00:00 2001
+From 31bd32fd65f005c5f8b63e6463da620ef363d856 Mon Sep 17 00:00:00 2001
From: Didier Raboud <odyx@debian.org>
Date: Sun, 27 Aug 2017 17:19:03 +0200
Subject: In the asciidoc call, use the '-a footer-style=none' to export
diff --git a/debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch b/debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch
index a227283..395f611 100644
--- a/debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch
+++ b/debian/patches/0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch
@@ -1,4 +1,4 @@
-From 6ef8a2e97e5721d1ce47a099d771443d12549dde Mon Sep 17 00:00:00 2001
+From 284f5512a2ce177da6fedf03ce39f38a28acc923 Mon Sep 17 00:00:00 2001
From: Steve Bennett <steveb@workware.net.au>
Date: Sun, 27 Aug 2017 10:13:07 +1000
Subject: tests/exec.test: Minor fix for exec-12.1 on hurd
diff --git a/debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch b/debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch
index dd8e6c1..23bfdfd 100644
--- a/debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch
+++ b/debian/patches/0004-tests-timer.test-Remove-timer-6.5.patch
@@ -1,4 +1,4 @@
-From 99c06db00087a368c0be7b00c71ba9b01d4797ca Mon Sep 17 00:00:00 2001
+From ef7310242ab5bd0daead9497d3f143f11a6cd2fa Mon Sep 17 00:00:00 2001
From: Steve Bennett <steveb@workware.net.au>
Date: Sun, 27 Aug 2017 10:14:14 +1000
Subject: tests/timer.test: Remove timer-6.5
diff --git a/debian/patches/series b/debian/patches/series
index 195774c..6a9e656 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,4 @@
-0001-Make-autosetup-accept-disable-enable-silent-rules-by.patch
+0001-Let-autosetup-accept-silent-rules-and-runstatedir-op.patch
0002-In-the-asciidoc-call-use-the-a-footer-style-none-to-.patch
0003-tests-exec.test-Minor-fix-for-exec-12.1-on-hurd.patch
0004-tests-timer.test-Remove-timer-6.5.patch