summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xOpenSP.xs4
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/SGML-Parser-OpenSP-0.994-Stop-using-deprecated-uvuni_to_utf8_flags.patch31
-rw-r--r--debian/patches/series1
5 files changed, 43 insertions, 3 deletions
diff --git a/OpenSP.xs b/OpenSP.xs
index dad5f7d..c8bdd60 100755
--- a/OpenSP.xs
+++ b/OpenSP.xs
@@ -162,7 +162,7 @@ SV* SgmlParserOpenSP::cs2sv(const SGMLApplication::CharString s)
{
d = m_temp;
for (i = 0; i < s.len; ++i)
- d = uvuni_to_utf8_flags(d, s.ptr[i], 0);
+ d = uvoffuni_to_utf8_flags(d, s.ptr[i], 0);
result = newSVpvn((const char*)m_temp, d - m_temp);
}
else
@@ -171,7 +171,7 @@ SV* SgmlParserOpenSP::cs2sv(const SGMLApplication::CharString s)
for (i = 0; i < s.len; ++i)
{
d = (U8 *)SvGROW(result, SvCUR(result) + UTF8_MAXLEN + 1);
- d = uvuni_to_utf8_flags(d + SvCUR(result), s.ptr[i], 0);
+ d = uvoffuni_to_utf8_flags(d + SvCUR(result), s.ptr[i], 0);
SvCUR_set(result, d - (U8 *)SvPVX(result));
}
}
diff --git a/debian/changelog b/debian/changelog
index 48dc329..707f02b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libsgml-parser-opensp-perl (0.994-7) unstable; urgency=medium
+
+ * Team upload.
+ * Add patch from CPAN RT to fix build failure with perl >= 5.37.1
+ * Declare compliance with Debian Policy 4.6.2.
+
+ -- gregor herrmann <gregoa@debian.org> Sun, 02 Jul 2023 21:14:47 +0200
+
libsgml-parser-opensp-perl (0.994-6) unstable; urgency=medium
* Team upload.
diff --git a/debian/control b/debian/control
index 035bd47..9f39575 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,7 @@ Build-Depends: debhelper-compat (= 13),
libtest-pod-perl <!nocheck>,
perl-xs-dev,
perl:native
-Standards-Version: 4.6.1
+Standards-Version: 4.6.2
Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libsgml-parser-opensp-perl
Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libsgml-parser-opensp-perl.git
Homepage: https://metacpan.org/release/SGML-Parser-OpenSP
diff --git a/debian/patches/SGML-Parser-OpenSP-0.994-Stop-using-deprecated-uvuni_to_utf8_flags.patch b/debian/patches/SGML-Parser-OpenSP-0.994-Stop-using-deprecated-uvuni_to_utf8_flags.patch
new file mode 100644
index 0000000..f429af7
--- /dev/null
+++ b/debian/patches/SGML-Parser-OpenSP-0.994-Stop-using-deprecated-uvuni_to_utf8_flags.patch
@@ -0,0 +1,31 @@
+Description: error: 'uvuni_to_utf8_flags' was not declared in this scope
+ The build failed since Perl 5.37.1. It is caused, because many deprecated C functions were removed.
+ https://metacpan.org/release/SHAY/perl-5.37.11/view/pod/perl5371delta.pod#Deprecations
+Origin: CPAN RT#148488
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=148488
+Forwarded: https://rt.cpan.org/Public/Bug/Display.html?id=148488
+Author: jplesnik@redhat.com
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2023-07-02
+
+diff -up SGML-Parser-OpenSP-0.994/OpenSP.xs.orig SGML-Parser-OpenSP-0.994/OpenSP.xs
+--- SGML-Parser-OpenSP-0.994/OpenSP.xs.orig 2023-06-05 09:39:32.643052849 +0200
++++ SGML-Parser-OpenSP-0.994/OpenSP.xs 2023-06-05 09:40:17.152435589 +0200
+@@ -162,7 +162,7 @@ SV* SgmlParserOpenSP::cs2sv(const SGMLAp
+ {
+ d = m_temp;
+ for (i = 0; i < s.len; ++i)
+- d = uvuni_to_utf8_flags(d, s.ptr[i], 0);
++ d = uvoffuni_to_utf8_flags(d, s.ptr[i], 0);
+ result = newSVpvn((const char*)m_temp, d - m_temp);
+ }
+ else
+@@ -171,7 +171,7 @@ SV* SgmlParserOpenSP::cs2sv(const SGMLAp
+ for (i = 0; i < s.len; ++i)
+ {
+ d = (U8 *)SvGROW(result, SvCUR(result) + UTF8_MAXLEN + 1);
+- d = uvuni_to_utf8_flags(d + SvCUR(result), s.ptr[i], 0);
++ d = uvoffuni_to_utf8_flags(d + SvCUR(result), s.ptr[i], 0);
+ SvCUR_set(result, d - (U8 *)SvPVX(result));
+ }
+ }
diff --git a/debian/patches/series b/debian/patches/series
index 85c58d3..4737cf5 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
doc_misspelling.patch
binnmu_rebuild_fix.patch
cross.patch
+SGML-Parser-OpenSP-0.994-Stop-using-deprecated-uvuni_to_utf8_flags.patch