summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rw-r--r--debian/patches/debian-changes42
-rw-r--r--debian/patches/series1
-rw-r--r--magit-annex-tests.el22
5 files changed, 64 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index 578d299..b23774d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+magit-annex (1.7.1-3) unstable; urgency=medium
+
+ * Drop spurious slash from end of Vcs-Git field value.
+ * Comment out magit-annex-unlock-lock-files test (Closes: #952304).
+ See https://github.com/magit/magit-annex/issues/23 -- test logic is
+ out-of-date.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Sun, 23 Feb 2020 10:19:43 -0700
+
magit-annex (1.7.1-2) unstable; urgency=medium
* Team upload.
diff --git a/debian/control b/debian/control
index d4c9ca1..fb9c33c 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,7 @@ Build-Depends: debhelper (>= 10),
dh-elpa,
Standards-Version: 4.1.0
Vcs-Browser: https://salsa.debian.org/emacsen-team/magit-annex
-Vcs-Git: https://salsa.debian.org/emacsen-team/magit-annex.git/
+Vcs-Git: https://salsa.debian.org/emacsen-team/magit-annex.git
Homepage: https://github.com/magit/magit-annex
Package: elpa-magit-annex
diff --git a/debian/patches/debian-changes b/debian/patches/debian-changes
new file mode 100644
index 0000000..0180ac9
--- /dev/null
+++ b/debian/patches/debian-changes
@@ -0,0 +1,42 @@
+The Debian packaging of magit-annex is maintained using dgit. For the
+sake of an efficient workflow, Debian modifications to the upstream
+source are squashed into a single diff, rather than a series of quilt
+patches. To obtain a patch queue for package version 1.2.3-1:
+
+ # apt-get install dgit
+ % dgit clone magit-annex
+ % cd magit-annex
+ % git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian'
+
+See dgit(1), dgit(7) and dgit-maint-merge(7) for more information.
+--- magit-annex-1.7.1.orig/magit-annex-tests.el
++++ magit-annex-1.7.1/magit-annex-tests.el
+@@ -267,17 +267,17 @@
+ (should (equal (magit-annex-present-files)
+ '("annex-file"))))))
+
+-(ert-deftest magit-annex-unlock-lock-files ()
+- (magit-annex-with-test-repo
+- (magit-annex-tests-modify-file "annex-file")
+- (magit-annex-add "annex-file")
+- (magit-call-git "commit" "-m" "annex commit")
+- (should-not (magit-annex-unlocked-files))
+- (magit-annex-unlock-files '("annex-file"))
+- (should (equal (magit-annex-unlocked-files)
+- '("annex-file")))
+- (magit-annex-lock-files '("annex-file") '("--force"))
+- (should-not (magit-annex-unlocked-files))))
++;; (ert-deftest magit-annex-unlock-lock-files ()
++;; (magit-annex-with-test-repo
++;; (magit-annex-tests-modify-file "annex-file")
++;; (magit-annex-add "annex-file")
++;; (magit-call-git "commit" "-m" "annex commit")
++;; (should-not (magit-annex-unlocked-files))
++;; (magit-annex-unlock-files '("annex-file"))
++;; (should (equal (magit-annex-unlocked-files)
++;; '("annex-file")))
++;; (magit-annex-lock-files '("annex-file") '("--force"))
++;; (should-not (magit-annex-unlocked-files))))
+
+ (ert-deftest magit-annex-undo-files ()
+ (magit-annex-with-test-repo
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..7bb8252
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+debian-changes
diff --git a/magit-annex-tests.el b/magit-annex-tests.el
index cf645ce..6e835ac 100644
--- a/magit-annex-tests.el
+++ b/magit-annex-tests.el
@@ -267,17 +267,17 @@
(should (equal (magit-annex-present-files)
'("annex-file"))))))
-(ert-deftest magit-annex-unlock-lock-files ()
- (magit-annex-with-test-repo
- (magit-annex-tests-modify-file "annex-file")
- (magit-annex-add "annex-file")
- (magit-call-git "commit" "-m" "annex commit")
- (should-not (magit-annex-unlocked-files))
- (magit-annex-unlock-files '("annex-file"))
- (should (equal (magit-annex-unlocked-files)
- '("annex-file")))
- (magit-annex-lock-files '("annex-file") '("--force"))
- (should-not (magit-annex-unlocked-files))))
+;; (ert-deftest magit-annex-unlock-lock-files ()
+;; (magit-annex-with-test-repo
+;; (magit-annex-tests-modify-file "annex-file")
+;; (magit-annex-add "annex-file")
+;; (magit-call-git "commit" "-m" "annex commit")
+;; (should-not (magit-annex-unlocked-files))
+;; (magit-annex-unlock-files '("annex-file"))
+;; (should (equal (magit-annex-unlocked-files)
+;; '("annex-file")))
+;; (magit-annex-lock-files '("annex-file") '("--force"))
+;; (should-not (magit-annex-unlocked-files))))
(ert-deftest magit-annex-undo-files ()
(magit-annex-with-test-repo