summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 3279bf7..454e7d1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+nlopt (2.7.1-2) unstable; urgency=medium
+
+ * Team upload
+ * d/rules: Install the python3.* extension to the correct path.
+ Thanks to Steve Langasek for the patch (Closes: #1001363)
+
+ -- Rafael Laboissière <rafael@debian.org> Sun, 12 Dec 2021 18:02:48 -0300
+
nlopt (2.7.1-1) unstable; urgency=medium
* Team upload
diff --git a/debian/rules b/debian/rules
index dde1e5b..ce2e465 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,7 +36,7 @@ override_dh_python3-arch:
distdir=debian/python3-nlopt/usr/lib/python3/dist-packages; \
mkdir -p $$distdir; \
for py3alt in $(PY3_ALT); do \
- py3short=`echo $${py3alt} | sed "s/\.//g"`; \
+ py3short=`echo $${py3alt} | sed "s/\.//g"`-`dpkg-architecture -qDEB_HOST_MULTIARCH`; \
cp $(BUILDDIR)-python$${py3alt}/src/swig/_nlopt.so $$distdir/_nlopt.cpython-$${py3short}.so; \
chrpath -d $$distdir/_nlopt.cpython-$${py3short}.so; \
done