summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore6
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/auto-gitignore20
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/yaml.patch26
-rw-r--r--debian/salsa-ci.yml5
-rw-r--r--lib/carto/mml.js2
7 files changed, 56 insertions, 12 deletions
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 8380543..0000000
--- a/.gitignore
+++ /dev/null
@@ -1,6 +0,0 @@
-**/node_modules
-.DS_Store
-test/rendering/layers/
-test/rendering/cache/
-test/rendering-mss/npm-debug.log
-docs/_build/
diff --git a/debian/changelog b/debian/changelog
index f367443..78f6941 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+node-carto (1.2.0-2) unstable; urgency=medium
+
+ * debian/salsa-ci.yml: disable aptly
+ * yaml.safeLoad is removed in js-yaml 4. Use yaml.load instead
+
+ -- Johannes Schauer Marin Rodrigues <josch@debian.org> Sat, 11 Dec 2021 00:06:26 +0100
+
node-carto (1.2.0-1) unstable; urgency=medium
[ Jérémy Lal ]
diff --git a/debian/patches/auto-gitignore b/debian/patches/auto-gitignore
new file mode 100644
index 0000000..a55e459
--- /dev/null
+++ b/debian/patches/auto-gitignore
@@ -0,0 +1,20 @@
+Subject: Update .gitignore from Debian packaging branch
+
+The Debian packaging git branch contains these updates to the upstream
+.gitignore file(s). This patch is autogenerated, to provide these
+updates to users of the official Debian archive view of the package.
+
+[dgit (9.14) update-gitignore]
+---
+diff --git a/.gitignore b/.gitignore
+deleted file mode 100644
+index 8380543..0000000
+--- a/.gitignore
++++ /dev/null
+@@ -1,6 +0,0 @@
+-**/node_modules
+-.DS_Store
+-test/rendering/layers/
+-test/rendering/cache/
+-test/rendering-mss/npm-debug.log
+-docs/_build/
diff --git a/debian/patches/series b/debian/patches/series
index c66bb56..61e6d0d 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,4 @@
disable-eslint.patch
fix-tests.patch
+yaml.patch
+auto-gitignore
diff --git a/debian/patches/yaml.patch b/debian/patches/yaml.patch
new file mode 100644
index 0000000..e85822b
--- /dev/null
+++ b/debian/patches/yaml.patch
@@ -0,0 +1,26 @@
+From 3951644f3f54a08d1eda6c328fe10710aaa49b05 Mon Sep 17 00:00:00 2001
+From: Johannes Schauer Marin Rodrigues <josch@mister-muffin.de>
+Date: Sat, 11 Dec 2021 00:02:21 +0100
+Subject: [PATCH] lib/carto/mml.js: FIX: Error: Function yaml.safeLoad is
+ removed in js-yaml 4. Use yaml.load instead, which is now safe by default.
+
+---
+ lib/carto/mml.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/carto/mml.js b/lib/carto/mml.js
+index aab6bc9..afacf62 100644
+--- a/lib/carto/mml.js
++++ b/lib/carto/mml.js
+@@ -22,7 +22,7 @@ carto.MML.prototype.load = function load(basedir, data, callback) {
+ env = {};
+
+ try {
+- mml = yaml.safeLoad(data);
++ mml = yaml.load(data);
+ } catch (err) {
+ env = {};
+ util.error(env, {
+--
+2.33.0
+
diff --git a/debian/salsa-ci.yml b/debian/salsa-ci.yml
index e748f6f..8424db4 100644
--- a/debian/salsa-ci.yml
+++ b/debian/salsa-ci.yml
@@ -1,8 +1,3 @@
---
include:
- https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/recipes/debian.yml
-
-before_script:
- - echo "deb [trusted=yes] https://salsa.debian.org/js-team/node-chroma-js/-/jobs/2190648/artifacts/raw/aptly unstable main" | tee /etc/apt/sources.list.d/node-chroma-js.list
- - echo "deb [trusted=yes] https://salsa.debian.org/js-team/node-hsluv/-/jobs/2190661/artifacts/raw/aptly unstable main" | tee /etc/apt/sources.list.d/node-hsluv.list
- - apt-get update
diff --git a/lib/carto/mml.js b/lib/carto/mml.js
index aab6bc9..afacf62 100644
--- a/lib/carto/mml.js
+++ b/lib/carto/mml.js
@@ -22,7 +22,7 @@ carto.MML.prototype.load = function load(basedir, data, callback) {
env = {};
try {
- mml = yaml.safeLoad(data);
+ mml = yaml.load(data);
} catch (err) {
env = {};
util.error(env, {