summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5f2f879..8687e55 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+node-chroma-js (2.1.1+dfsg-3) unstable; urgency=medium
+
+ * debian/rules: adapt regex -- variable can be named chroma or chroma_1
+
+ -- Johannes Schauer Marin Rodrigues <josch@debian.org> Fri, 10 Dec 2021 22:59:11 +0100
+
node-chroma-js (2.1.1+dfsg-2) unstable; urgency=medium
* source-only upload to allow migration to testing
diff --git a/debian/rules b/debian/rules
index 1cf0de2..04b10ba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@ override_dh_auto_build:
rollup -c
# workaround for https://github.com/gka/chroma.js/issues/284
dirname=$$(basename $$(pwd) | sed 's/[.+]/_/g; s/-\([a-z]\)/\U\1/g; s/-//g;'); \
- perl -0777 -i -pe 's/var '"$${dirname}"' = chroma_1;\n\n return '"$${dirname}"';/return chroma_1;/is' chroma.js
+ perl -0777 -i -pe 's/var '"$${dirname}"' = ([a-z0-9_]+);\n\n return '"$${dirname}"';/return $$1;/is' chroma.js
# manually calling uglify because node-rollup-plugin-uglify is not packaged
uglifyjs chroma.js > chroma.min.js
uglifyjs chroma-light.js > chroma-light.min.js