summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rw-r--r--debian/patches/0001-Use-C99-standard-int64_t-instead-of-OCaml-defined-an.patch4
-rw-r--r--debian/patches/10_disable-Werror.patch20
-rw-r--r--debian/patches/20_improve-GCC-hardening.patch18
-rw-r--r--debian/patches/Fix-compilation-with-safe-string.patch42
-rw-r--r--debian/patches/series1
-rw-r--r--libvirt/libvirt.ml4
-rw-r--r--libvirt/libvirt.mli4
9 files changed, 84 insertions, 21 deletions
diff --git a/debian/changelog b/debian/changelog
index a9369fe..49c8b18 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+ocaml-libvirt (0.6.1.4-3) unstable; urgency=medium
+
+ * Team upload
+ * Fix compilation with -safe-string
+ * Update Vcs-*
+
+ -- Stéphane Glondu <glondu@debian.org> Tue, 20 Aug 2019 07:50:04 +0200
+
ocaml-libvirt (0.6.1.4-2) unstable; urgency=medium
[ Stéphane Glondu ]
diff --git a/debian/control b/debian/control
index e39ac96..0f0210c 100644
--- a/debian/control
+++ b/debian/control
@@ -11,8 +11,8 @@ Build-Depends: cdbs,
ocaml-findlib,
ocaml-nox
Standards-Version: 3.9.8
-Vcs-Browser: https://anonscm.debian.org/git/pkg-ocaml-maint/packages/ocaml-libvirt.git
-Vcs-Git: https://anonscm.debian.org/git/pkg-ocaml-maint/packages/ocaml-libvirt.git
+Vcs-Browser: https://salsa.debian.org/ocaml-team/ocaml-libvirt
+Vcs-Git: https://salsa.debian.org/ocaml-team/ocaml-libvirt.git
Homepage: http://libvirt.org/ocaml/
Package: libvirt-ocaml
diff --git a/debian/patches/0001-Use-C99-standard-int64_t-instead-of-OCaml-defined-an.patch b/debian/patches/0001-Use-C99-standard-int64_t-instead-of-OCaml-defined-an.patch
index 1f29677..aaac6de 100644
--- a/debian/patches/0001-Use-C99-standard-int64_t-instead-of-OCaml-defined-an.patch
+++ b/debian/patches/0001-Use-C99-standard-int64_t-instead-of-OCaml-defined-an.patch
@@ -1,4 +1,3 @@
-From 21ac993da0a187821e812fe7b5b31a426121a546 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 30 Aug 2014 19:10:19 +0100
Subject: [PATCH] Use C99 standard int64_t instead of OCaml defined (and soon
@@ -30,6 +29,3 @@ index 3bb572f..06b3852 100644
Store_field (rv, i, iv);
}
---
-2.7.4
-
diff --git a/debian/patches/10_disable-Werror.patch b/debian/patches/10_disable-Werror.patch
index e07e837..60798a2 100644
--- a/debian/patches/10_disable-Werror.patch
+++ b/debian/patches/10_disable-Werror.patch
@@ -1,11 +1,19 @@
-Description: disable unnecessary option -Werror to avoid a FTBFS.
-Author: Joao Eriberto Mota Filho <eriberto@debian.org>
+From: Joao Eriberto Mota Filho <eriberto@debian.org>
+Date: Thu, 15 Aug 2019 14:29:56 +0200
+Subject: disable unnecessary option -Werror to avoid a FTBFS.
+
Last-Update: 2016-12-18
-Index: ocaml-libvirt-0.6.1.4/configure.ac
+
===================================================================
---- ocaml-libvirt-0.6.1.4.orig/configure.ac
-+++ ocaml-libvirt-0.6.1.4/configure.ac
-@@ -33,7 +33,7 @@ dnl Select some C flags based on the hos
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 758fcc5..4f131dd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,7 +33,7 @@ dnl Select some C flags based on the host type.
AC_CANONICAL_HOST
DEBUG="-g"
diff --git a/debian/patches/20_improve-GCC-hardening.patch b/debian/patches/20_improve-GCC-hardening.patch
index 88b4c39..c0279aa 100644
--- a/debian/patches/20_improve-GCC-hardening.patch
+++ b/debian/patches/20_improve-GCC-hardening.patch
@@ -1,10 +1,18 @@
-Description: add CPPFLAGS to improve the hardening.
-Author: Joao Eriberto Mota Filho <eriberto@debian.org>
+From: Joao Eriberto Mota Filho <eriberto@debian.org>
+Date: Thu, 15 Aug 2019 14:29:56 +0200
+Subject: add CPPFLAGS to improve the hardening.
+
Last-Update: 2016-12-18
-Index: ocaml-libvirt-0.6.1.4/libvirt/Makefile.in
+
===================================================================
---- ocaml-libvirt-0.6.1.4.orig/libvirt/Makefile.in
-+++ ocaml-libvirt-0.6.1.4/libvirt/Makefile.in
+---
+ libvirt/Makefile.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libvirt/Makefile.in b/libvirt/Makefile.in
+index f7c04bb..d772c14 100644
+--- a/libvirt/Makefile.in
++++ b/libvirt/Makefile.in
@@ -23,6 +23,7 @@ CFLAGS = @CFLAGS@ \
@DEBUG@ @WARNINGS@ @CFLAGS_FPIC@
LDFLAGS = @LDFLAGS@
diff --git a/debian/patches/Fix-compilation-with-safe-string.patch b/debian/patches/Fix-compilation-with-safe-string.patch
new file mode 100644
index 0000000..bc4b8a4
--- /dev/null
+++ b/debian/patches/Fix-compilation-with-safe-string.patch
@@ -0,0 +1,42 @@
+From: Stephane Glondu <steph@glondu.net>
+Date: Thu, 15 Aug 2019 14:39:26 +0200
+Subject: Fix compilation with -safe-string
+
+---
+ libvirt/libvirt.ml | 4 ++--
+ libvirt/libvirt.mli | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/libvirt/libvirt.ml b/libvirt/libvirt.ml
+index 9c9368a..3b996ee 100644
+--- a/libvirt/libvirt.ml
++++ b/libvirt/libvirt.ml
+@@ -93,10 +93,10 @@ struct
+ (* See VIR_USE_CPU, VIR_UNUSE_CPU, VIR_CPU_USABLE macros defined in <libvirt.h>. *)
+ let use_cpu cpumap cpu =
+ cpumap.[cpu/8] <-
+- Char.chr (Char.code cpumap.[cpu/8] lor (1 lsl (cpu mod 8)))
++ Char.chr (Char.code (Bytes.get cpumap (cpu/8)) lor (1 lsl (cpu mod 8)))
+ let unuse_cpu cpumap cpu =
+ cpumap.[cpu/8] <-
+- Char.chr (Char.code cpumap.[cpu/8] land (lnot (1 lsl (cpu mod 8))))
++ Char.chr (Char.code (Bytes.get cpumap (cpu/8)) land (lnot (1 lsl (cpu mod 8))))
+ let cpu_usable cpumaps maplen vcpu cpu =
+ Char.code cpumaps.[vcpu*maplen + cpu/8] land (1 lsl (cpu mod 8)) <> 0
+
+diff --git a/libvirt/libvirt.mli b/libvirt/libvirt.mli
+index 36cd113..04beb19 100644
+--- a/libvirt/libvirt.mli
++++ b/libvirt/libvirt.mli
+@@ -376,9 +376,9 @@ sig
+ CPU map between a single virtual and all physical CPUs of a domain.
+ *)
+
+- val use_cpu : string -> int -> unit
++ val use_cpu : bytes -> int -> unit
+ (** [use_cpu cpumap cpu] marks [cpu] as usable in [cpumap]. *)
+- val unuse_cpu : string -> int -> unit
++ val unuse_cpu : bytes -> int -> unit
+ (** [unuse_cpu cpumap cpu] marks [cpu] as not usable in [cpumap]. *)
+ val cpu_usable : string -> int -> int -> int -> bool
+ (** [cpu_usable cpumaps maplen vcpu cpu] checks returns true iff the
diff --git a/debian/patches/series b/debian/patches/series
index 6f10267..1ba28a0 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
10_disable-Werror.patch
20_improve-GCC-hardening.patch
0001-Use-C99-standard-int64_t-instead-of-OCaml-defined-an.patch
+Fix-compilation-with-safe-string.patch
diff --git a/libvirt/libvirt.ml b/libvirt/libvirt.ml
index 9c9368a..3b996ee 100644
--- a/libvirt/libvirt.ml
+++ b/libvirt/libvirt.ml
@@ -93,10 +93,10 @@ struct
(* See VIR_USE_CPU, VIR_UNUSE_CPU, VIR_CPU_USABLE macros defined in <libvirt.h>. *)
let use_cpu cpumap cpu =
cpumap.[cpu/8] <-
- Char.chr (Char.code cpumap.[cpu/8] lor (1 lsl (cpu mod 8)))
+ Char.chr (Char.code (Bytes.get cpumap (cpu/8)) lor (1 lsl (cpu mod 8)))
let unuse_cpu cpumap cpu =
cpumap.[cpu/8] <-
- Char.chr (Char.code cpumap.[cpu/8] land (lnot (1 lsl (cpu mod 8))))
+ Char.chr (Char.code (Bytes.get cpumap (cpu/8)) land (lnot (1 lsl (cpu mod 8))))
let cpu_usable cpumaps maplen vcpu cpu =
Char.code cpumaps.[vcpu*maplen + cpu/8] land (1 lsl (cpu mod 8)) <> 0
diff --git a/libvirt/libvirt.mli b/libvirt/libvirt.mli
index 36cd113..04beb19 100644
--- a/libvirt/libvirt.mli
+++ b/libvirt/libvirt.mli
@@ -376,9 +376,9 @@ sig
CPU map between a single virtual and all physical CPUs of a domain.
*)
- val use_cpu : string -> int -> unit
+ val use_cpu : bytes -> int -> unit
(** [use_cpu cpumap cpu] marks [cpu] as usable in [cpumap]. *)
- val unuse_cpu : string -> int -> unit
+ val unuse_cpu : bytes -> int -> unit
(** [unuse_cpu cpumap cpu] marks [cpu] as not usable in [cpumap]. *)
val cpu_usable : string -> int -> int -> int -> bool
(** [cpu_usable cpumaps maplen vcpu cpu] checks returns true iff the