summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/copyright_hints57
-rw-r--r--debian/patches/auto-gitignore2
-rwxr-xr-xdebian/rules12
4 files changed, 77 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f5a230d..6dec541 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+pd-bassemu (0.3-9) unstable; urgency=medium
+
+ * Add 'licensecheck' target
+ + Generate d/copyright_hints
+
+ -- IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org> Thu, 24 Nov 2022 23:00:49 +0100
+
pd-bassemu (0.3-8) unstable; urgency=medium
[ Debian Janitor ]
diff --git a/debian/copyright_hints b/debian/copyright_hints
new file mode 100644
index 0000000..fc99891
--- /dev/null
+++ b/debian/copyright_hints
@@ -0,0 +1,57 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: FIXME
+Upstream-Contact: FIXME
+Source: FIXME
+Disclaimer: Autogenerated by licensecheck
+
+Files: Makefile
+ Makefile.nt
+ bassemu~-help.pd
+ bassemu~-meta.pd
+ debian/changelog
+ debian/control
+ debian/gbp.conf
+ debian/links
+ debian/patches/makefile_update_for_kfreebsd_and_hurd
+ debian/patches/series
+ debian/rules
+ debian/salsa-ci.yml
+ debian/source/format
+ debian/upstream/metadata
+ debian/watch
+ miniseq.pd
+Copyright: NONE
+License: UNKNOWN
+ FIXME
+
+Files: debian/copyright_hints
+Copyright: 1989, 1991, Free Software Foundation, Inc.
+ 2006, Ch. Klippel
+ 2006, Christian Klippel
+ Copyright: 2006, Christian Klippel
+ NONE
+License: GPL-2
+ FIXME
+
+Files: LICENSE.txt
+Copyright: 1989, 1991, Free Software Foundation, Inc.
+License: GPL-2
+ FIXME
+
+Files: debian/copyright
+Copyright: 2006, Christian Klippel
+ 2010, Hans-Christoph Steiner <hans@eds.org>
+License: GPL-2+
+ FIXME
+
+Files: README.txt
+Copyright: 2006, Ch. Klippel
+License: UNKNOWN
+ FIXME
+
+Files: bassemu~.c
+Copyright: 2006, Ch. Klippel
+ 2006, Ch. Klippel - ck@mamalala.de");
+License: UNKNOWN
+ FIXME
+
diff --git a/debian/patches/auto-gitignore b/debian/patches/auto-gitignore
index 7a15c5c..d59ea67 100644
--- a/debian/patches/auto-gitignore
+++ b/debian/patches/auto-gitignore
@@ -4,7 +4,7 @@ The Debian packaging git branch contains these updates to the upstream
.gitignore file(s). This patch is autogenerated, to provide these
updates to users of the official Debian archive view of the package.
-[dgit (10.0) update-gitignore]
+[dgit (10.1) update-gitignore]
---
diff --git a/.gitignore b/.gitignore
new file mode 100644
diff --git a/debian/rules b/debian/rules
index 2504e0c..b9888b3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,3 +15,15 @@ override_dh_auto_install:
dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir) STRIP=true
# replace license file with link to the Debian license file
rm -f -- $(CURDIR)/debian/*/$(pkglibdir)/*/LICENSE.txt
+
+DEB_COPYRIGHT_CHECK_IGNORE_REGEX = \
+ $(empty)
+# licensecheck v1
+.PHONY: licensecheck
+licensecheck:
+ licensecheck \
+ -i "^($(DEB_COPYRIGHT_CHECK_IGNORE_REGEX))$$" \
+ --check '.*' --recursive --deb-machine --lines 0 * \
+ > debian/copyright_newhints
+ cmp debian/copyright_hints debian/copyright_newhints \
+ && rm debian/copyright_newhints