summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PKG-INFO6
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rw-r--r--debian/copyright4
-rw-r--r--plakativ.appdata.xml2
-rw-r--r--plakativ.egg-info/PKG-INFO6
-rwxr-xr-xplakativ.py12
-rw-r--r--setup.py4
8 files changed, 27 insertions, 16 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 99abe65..b7e5aef 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,12 +1,12 @@
Metadata-Version: 1.1
Name: plakativ
-Version: 0.4
+Version: 0.5
Summary: Convert a PDF into a large poster that can be printed on multiple smaller pages.
Home-page: https://gitlab.mister-muffin.de/josch/plakativ
-Author: Johannes 'josch' Schauer
+Author: Johannes Schauer Marin Rodrigues
Author-email: josch@mister-muffin.de
License: GPL-3
-Download-URL: https://gitlab.mister-muffin.de/josch/plakativ/repository/archive.tar.gz?ref=0.4
+Download-URL: https://gitlab.mister-muffin.de/josch/plakativ/repository/archive.tar.gz?ref=0.5
Description: file: README.md, CHANGELOG.rst
Keywords: pdf poster
Platform: UNKNOWN
diff --git a/debian/changelog b/debian/changelog
index aa21410..77f0460 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+plakativ (0.5-1) unstable; urgency=medium
+
+ * New upstream version 0.5
+ * update my name
+
+ -- Johannes Schauer Marin Rodrigues <josch@debian.org> Wed, 13 Oct 2021 09:06:02 +0200
+
plakativ (0.4-1) unstable; urgency=medium
* new upstream release
diff --git a/debian/control b/debian/control
index a1c832e..2f2f420 100644
--- a/debian/control
+++ b/debian/control
@@ -1,5 +1,5 @@
Source: plakativ
-Maintainer: Johannes 'josch' Schauer <josch@debian.org>
+Maintainer: Johannes Schauer Marin Rodrigues <josch@debian.org>
Section: python
Priority: optional
Build-Depends: debhelper-compat (= 13),
diff --git a/debian/copyright b/debian/copyright
index 7a2d85d..3ae1869 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -3,13 +3,13 @@ Upstream-Name: plakativ
Source: https://gitlab.mister-muffin.de/josch/plakativ
Files: *
-Copyright: 2019-2020 Johannes Schauer <josch@debian.org>
+Copyright: 2019-2020 Johannes Schauer Marin Rodrigues <josch@debian.org>
2015-2017 Terry Jan Reedy
2000 Fredrik Lundh
License: GPL-3 and PSF
Files: plakativ.appdata.xml
-Copyright: 2020 Johannes Schauer <josch@debian.org>
+Copyright: 2020 Johannes Schauer Marin Rodrigues <josch@debian.org>
License: FSFAP
Copying and distribution of this file, with or without modification,
are permitted in any medium without royalty provided the copyright
diff --git a/plakativ.appdata.xml b/plakativ.appdata.xml
index 092088f..cd66602 100644
--- a/plakativ.appdata.xml
+++ b/plakativ.appdata.xml
@@ -7,7 +7,7 @@
<metadata_license>FSFAP</metadata_license>
<project_license>GPL-3.0</project_license>
- <developer_name>Johannes Schauer</developer_name>
+ <developer_name>Johannes Schauer Marin Rodrigues</developer_name>
<description>
<p>
diff --git a/plakativ.egg-info/PKG-INFO b/plakativ.egg-info/PKG-INFO
index 99abe65..b7e5aef 100644
--- a/plakativ.egg-info/PKG-INFO
+++ b/plakativ.egg-info/PKG-INFO
@@ -1,12 +1,12 @@
Metadata-Version: 1.1
Name: plakativ
-Version: 0.4
+Version: 0.5
Summary: Convert a PDF into a large poster that can be printed on multiple smaller pages.
Home-page: https://gitlab.mister-muffin.de/josch/plakativ
-Author: Johannes 'josch' Schauer
+Author: Johannes Schauer Marin Rodrigues
Author-email: josch@mister-muffin.de
License: GPL-3
-Download-URL: https://gitlab.mister-muffin.de/josch/plakativ/repository/archive.tar.gz?ref=0.4
+Download-URL: https://gitlab.mister-muffin.de/josch/plakativ/repository/archive.tar.gz?ref=0.5
Description: file: README.md, CHANGELOG.rst
Keywords: pdf poster
Platform: UNKNOWN
diff --git a/plakativ.py b/plakativ.py
index 1c78048..0b30ff1 100755
--- a/plakativ.py
+++ b/plakativ.py
@@ -6,7 +6,7 @@
# pieces and putting each of them onto a paper size that can be printed
# normally. The result can then be glued together into a bigger poster.
#
-# Copyright (C) 2019 Johannes 'josch' Schauer
+# Copyright (C) 2019 - 2021 Johannes Schauer Marin Rodrigues <josch@mister-muffin.de>
#
# This program is free software: you can redistribute it and/or modify it under
# the terms of the GNU General Public License version 3 as published by the
@@ -46,7 +46,7 @@ except ImportError:
tkinter.Menubutton = dummy
tkinter.LabelFrame = dummy
-VERSION = "0.4"
+VERSION = "0.5"
PAGE_SIZES = OrderedDict(
[
@@ -369,6 +369,10 @@ class Plakativ:
printable_height = self.layout["output_pagesize"][1] - (
border_top + border_bottom
)
+ # these may fail with "RuntimeError: image is too wide"
+ # from pdf_load_image_imp() in pdf-image.c from mupdf for sizes larger
+ # than 1<<16 pixels:
+ # https://bugs.ghostscript.com/show_bug.cgi?id=703839
inpage_width = pt_to_mm(self.doc[self.pagenr].getDisplayList().rect.width)
inpage_height = pt_to_mm(self.doc[self.pagenr].getDisplayList().rect.height)
@@ -879,7 +883,7 @@ class VerticalScrolledFrame(tkinter.Frame):
borderwidth=0,
highlightthickness=0,
yscrollcommand=vscrollbar.set,
- width=240,
+ width=240 * parent.winfo_fpixels("1i") / 96.0,
)
canvas.pack(side=tkinter.LEFT, fill=tkinter.BOTH, expand=tkinter.TRUE)
vscrollbar.config(command=canvas.yview)
@@ -2202,7 +2206,7 @@ you can instruct plakativ to remove the alpha channel for you with the
$ plakativ --size A1 --output=poster.pdf --remove-alpha input.png
-Written by Johannes 'josch' Schauer <josch@mister-muffin.de>
+Written by Johannes Schauer Marin Rodrigues <josch@mister-muffin.de>
Report bugs at https://gitlab.mister-muffin.de/josch/plakativ/issues
"""
diff --git a/setup.py b/setup.py
index 66c5fb5..e2f2152 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,11 @@
from setuptools import setup
-VERSION = "0.4"
+VERSION = "0.5"
setup(
name="plakativ",
version=VERSION,
- author="Johannes 'josch' Schauer",
+ author="Johannes Schauer Marin Rodrigues",
author_email="josch@mister-muffin.de",
description="Convert a PDF into a large poster that can be printed on multiple smaller pages.",
long_description="file: README.md, CHANGELOG.rst",