summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog15
-rw-r--r--debian/control4
-rw-r--r--debian/copyright7
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/tests/run-unit-test2
-rw-r--r--debian/watch11
6 files changed, 32 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 18d63d5..1dda8ce 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+python-pymummer (0.11.0-3) unstable; urgency=medium
+
+ * Team upload.
+ * Update standards version to 4.6.1, no changes needed.
+ * Update watch file format version to 4.
+ * d/watch: move to git mode instead of web scraping; in both cases we scan
+ for git tags, so git mode is probably more robust.
+ * d/t/run-unit-test: run against all supported python3 versions.
+ * d/copyright: update debian maintainers over the years.
+ * d/control: switch from nose to pytest.
+ * d/rules: invoke pytest instead of setup.py.
+ Closes: #1018565
+
+ -- Étienne Mollier <emollier@debian.org> Sat, 03 Dec 2022 17:22:28 +0100
+
python-pymummer (0.11.0-2) unstable; urgency=medium
* Team Upload.
diff --git a/debian/control b/debian/control
index a6f2d7f..238034a 100644
--- a/debian/control
+++ b/debian/control
@@ -11,8 +11,8 @@ Build-Depends: debhelper-compat (= 13),
python3-setuptools,
fastaq (>=3.10.0),
mummer,
- python3-nose <!nocheck>
-Standards-Version: 4.5.0
+ python3-pytest <!nocheck>
+Standards-Version: 4.6.1
Vcs-Browser: https://salsa.debian.org/med-team/python-pymummer
Vcs-Git: https://salsa.debian.org/med-team/python-pymummer.git
Homepage: https://github.com/sanger-pathogens/pymummer
diff --git a/debian/copyright b/debian/copyright
index 450527f..b8cbbb1 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -9,7 +9,12 @@ Copyright: 2015-2016 Martin Hunt <path-help@sanger.ac.uk>
License: GPL-3.0
Files: debian/*
-Copyright: 2015-2016 Afif Elghraoui <afif@debian.org>
+Copyright: 2015-2019 Afif Elghraoui <afif@debian.org>
+ 2016-2018 Sascha Steinbiss <satta@debian.org>
+ 2019 Andreas Tille <tille@debian.org>
+ 2019-2020 Steffen Möller <moeller@debian.org>
+ 2020 Nilesh Patra <nilesh@debian.org>
+ 2022 Étienne Mollier <emollier@debian.org>
License: GPL-3.0
License: GPL-3.0
diff --git a/debian/rules b/debian/rules
index e19ff93..a7b286d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,7 @@ export PYBUILD_NAME=pymummer
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
PYBUILD_SYSTEM=custom \
- PYBUILD_TEST_ARGS="{interpreter} setup.py test" \
+ PYBUILD_TEST_ARGS="{interpreter} -m pytest" \
dh_auto_test
endif
diff --git a/debian/tests/run-unit-test b/debian/tests/run-unit-test
index 0b19e00..6565d40 100644
--- a/debian/tests/run-unit-test
+++ b/debian/tests/run-unit-test
@@ -1,7 +1,7 @@
#!/bin/bash
set -e
-for py in $(py3versions -r 2> /dev/null)
+for py in $(py3versions --supported)
do
$py -m pytest -v
done
diff --git a/debian/watch b/debian/watch
index a586a89..e6ebbf1 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,4 +1,7 @@
-version=3
-
-opts="filenamemangle=s/(?:.*?)?v?(\d[\d.]*)\.tar\.gz/python-pymummer-$1.tar.gz/" \
- https://github.com/sanger-pathogens/pymummer/tags (?:.*?/)?v?(\d[\d.]*)\.tar\.gz
+version=4
+opts=" \
+ mode=git, \
+ filenamemangle=s/(?:.*?)?v?(\d[\d.]*)\.tar\.gz/python-pymummer-$1.tar.gz/ \
+" \
+https://github.com/sanger-pathogens/pymummer.git \
+refs/tags/v?@ANY_VERSION@