summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rw-r--r--debian/control2
-rw-r--r--debian/copyright2
-rw-r--r--debian/patches/openssl-3.patch16
-rw-r--r--debian/patches/series1
-rw-r--r--debian/source/lintian-overrides4
-rw-r--r--debian/watch2
-rw-r--r--libcperciva/crypto/crypto_aes.c2
8 files changed, 36 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 1a4fe7d..f4b9e26 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+spiped (1.6.2-3) unstable; urgency=medium
+
+ * Fix the watch file: the upstream site's spiped/ directory is not
+ indexable any more.
+ * Fix FTBFS by silencing OpenSSL warnings about functions deprecated in
+ OpenSSL 3.x.
+ * Declare compliance with Policy 4.6.2 with no changes.
+ * Add the year 2023 to my debian/* copyright notice.
+ * Catch up with Lintian warnings format changes.
+
+ -- Peter Pentchev <roam@debian.org> Sat, 07 Jan 2023 04:39:23 +0200
+
spiped (1.6.2-2) unstable; urgency=medium
* Pass O_RDONLY, not 0, to sysopen() in the autopkgtest so that
diff --git a/debian/control b/debian/control
index 781a8cf..5f44778 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends:
procps,
netcat-openbsd <!nocheck>,
perl <!nocheck>,
-Standards-Version: 4.6.0
+Standards-Version: 4.6.2
Homepage: https://www.tarsnap.com/spiped.html
Vcs-Git: https://gitlab.com/spiped/spiped.git -b debian/master
Vcs-Browser: https://gitlab.com/spiped/spiped/tree/debian/master
diff --git a/debian/copyright b/debian/copyright
index 42e2226..0342249 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -18,7 +18,7 @@ Copyright:
License: BSD-2-clause
Files: debian/*
-Copyright: 2012-2014, 2016-2022 Peter Pentchev <roam@debian.org>
+Copyright: 2012-2014, 2016-2023 Peter Pentchev <roam@debian.org>
License: BSD-2-clause
License: BSD-2-clause
diff --git a/debian/patches/openssl-3.patch b/debian/patches/openssl-3.patch
new file mode 100644
index 0000000..8ac57da
--- /dev/null
+++ b/debian/patches/openssl-3.patch
@@ -0,0 +1,16 @@
+Description: Suppress the OpenSSL warnings about functions deprecated in 3.x
+Forwarded: no
+Author: Peter Pentchev <roam@ringlet.net>
+Last-Update: 2023-01-07
+
+--- a/libcperciva/crypto/crypto_aes.c
++++ b/libcperciva/crypto/crypto_aes.c
+@@ -3,6 +3,8 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++#define OPENSSL_SUPPRESS_DEPRECATED
++
+ #include <openssl/aes.h>
+
+ #include "cpusupport.h"
diff --git a/debian/patches/series b/debian/patches/series
index 82c6881..03f5d21 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
debian-build.patch
hurd.patch
+openssl-3.patch
diff --git a/debian/source/lintian-overrides b/debian/source/lintian-overrides
index f18b25d..de56eea 100644
--- a/debian/source/lintian-overrides
+++ b/debian/source/lintian-overrides
@@ -1,5 +1,5 @@
# The upstream Makefiles contain long lists of files that are
# not split across lines.
#
-spiped source: very-long-line-length-in-source-file liball/Makefile *
-spiped source: very-long-line-length-in-source-file perftests/standalone-enc/Makefile *
+spiped source: very-long-line-length-in-source-file * [liball/Makefile:*]
+spiped source: very-long-line-length-in-source-file * [perftests/standalone-enc/Makefile:*]
diff --git a/debian/watch b/debian/watch
index 777f542..6f6bb19 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,3 +1,3 @@
version=4
opts=pgpmode=none \
-https://www.tarsnap.com/spiped/ spiped-([\d.]*)\.tgz
+https://www.tarsnap.com/spiped.html spiped/spiped-([\d.]*)\.tgz
diff --git a/libcperciva/crypto/crypto_aes.c b/libcperciva/crypto/crypto_aes.c
index eba06f4..e07dc80 100644
--- a/libcperciva/crypto/crypto_aes.c
+++ b/libcperciva/crypto/crypto_aes.c
@@ -3,6 +3,8 @@
#include <stdlib.h>
#include <string.h>
+#define OPENSSL_SUPPRESS_DEPRECATED
+
#include <openssl/aes.h>
#include "cpusupport.h"