summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control20
-rw-r--r--debian/copyright32
-rw-r--r--debian/links2
-rw-r--r--debian/lintian-overrides3
-rwxr-xr-xdebian/rules50
7 files changed, 113 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..709a381
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+9mount (1.3-1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Daniel Baumann <daniel@debian.org> Sun, 3 Aug 2008 16:10:00 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..0beca97
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,20 @@
+Source: 9mount
+Section: admin
+Priority: optional
+Maintainer: Daniel Baumann <daniel@debian.org>
+Build-Depends: debhelper (>= 7)
+Standards-Version: 3.8.0
+Homepage: http://sqweek.dnsdojo.org/code/9mount/
+Vcs-Browser: http://git.debian.net/?p=9mount.git
+Vcs-Git: git://git.debian.net/git/9mount.git
+
+Package: 9mount
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: plan9 filesystem (v9fs) user mount utilities
+ 9mount is a set of SUID mounting tools for use with v9fs to help cope with
+ linux's poor mount support.
+ .
+ The tools offer a level of security - 9mount will only let you mount over
+ non-sticky directories you have write access to, and 9umount will only let you
+ unmount 9p partitions that you mounted yourself.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..300cad9
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,32 @@
+Author: sqweek <sqweek@gmail.com>
+Download: http://sqweek.dnsdojo.org/code/9mount/
+
+Files: *
+Copyright: (C) 2008 sqweek <sqweek@gmail.com>
+License: ISC
+ Permission to use, copy, modify, and/or distribute this software for any
+ purpose with or without fee is hereby granted, provided that the above
+ copyright notice and this permission notice appear in all copies.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+Files: debian/*
+Copyright: (C) 2008 Daniel Baumann <daniel@debian.org>
+License: ISC
+ Permission to use, copy, modify, and/or distribute this software for any
+ purpose with or without fee is hereby granted, provided that the above
+ copyright notice and this permission notice appear in all copies.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/debian/links b/debian/links
new file mode 100644
index 0000000..8221869
--- /dev/null
+++ b/debian/links
@@ -0,0 +1,2 @@
+/usr/share/man/man1/9mount.1.gz /usr/share/man/man1/9bind.1.gz
+/usr/share/man/man1/9mount.1.gz /usr/share/man/man1/9umount.1.gz
diff --git a/debian/lintian-overrides b/debian/lintian-overrides
new file mode 100644
index 0000000..46a6ce4
--- /dev/null
+++ b/debian/lintian-overrides
@@ -0,0 +1,3 @@
+9mount: setuid-binary usr/bin/9bind 4755 root/root
+9mount: setuid-binary usr/bin/9mount 4755 root/root
+9mount: setuid-binary usr/bin/9umount 4755 root/root
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..855687f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ $(MAKE) clean
+
+ dh_clean
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ $(MAKE)
+
+ touch build-stamp
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) prefix=$(CURDIR)/debian/9mount/usr install
+
+ chown root:root debian/9mount/usr/bin/*
+
+binary: binary-arch
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+ dh_lintian
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms -Xusr/bin/9bind -Xusr/bin/9mount -Xusr/bin/9umount
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-indep:
+
+.PHONY: clean build install binary binary-arch binary-indep