summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2014-10-20 17:03:42 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2014-10-20 17:09:18 +0100
commit3665739ce3e08c43b268e50d83de2fd52a67e694 (patch)
tree3a499841f9f19ceb2f35b2e8a8fe826a00a3ae99
parentf29e7003361bb2b93f7de60198214c612ae55cd4 (diff)
Build system: Add test case output and common.make to `make [dist]clean'.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--Makefile.in3
-rw-r--r--debian/changelog3
-rw-r--r--settings.make.in2
3 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 182dc13..5151ade 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -51,7 +51,8 @@ clean-here mostlyclean-here:
rm -rf dist_tmp web adnshost.txt
distclean-here maintainer-clean-here: clean-here
- rm -f settings.make config.cache config.log config.status Makefile
+ rm -f settings.make common.make
+ rm -f config.cache config.log config.status Makefile
install-strip:
$(MAKE) INSTALL_PROGRAM_FLAGS=-s
diff --git a/debian/changelog b/debian/changelog
index 9e60037..00ec9fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,8 +12,9 @@ adns (1.5.0~rc0-0~exp1) experimental; urgency=low
* Add ${misc:Depends} to quieten lintian (no change to the .debs).
* Support dpkg-buildflags (ie, build with hardening).
* Patch regress/Makefile.in to fix problem with .SECONDARY declaration.
+ * Add test case output and common.make to `make [dist]clean'.
- -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 20 Oct 2014 16:34:44 +0100
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 20 Oct 2014 17:09:12 +0100
adns (1.4-2) unstable; urgency=low
diff --git a/settings.make.in b/settings.make.in
index 81e1bb3..3e14589 100644
--- a/settings.make.in
+++ b/settings.make.in
@@ -27,6 +27,8 @@ all: $(TARGETS)
clean mostlyclean:
rm -f *.o *.tmp* *.so *.so.* pipe.*
+ rm -f output-*.err output-*.leftover
+ rm -f output-*.out output-*.report
distclean: clean
rm -f $(TARGETS) *~ ./#*# core *.orig *.rej Makefile config.h