summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Holmgren <holmgren@debian.org>2019-08-26 00:46:01 +0200
committerMagnus Holmgren <holmgren@debian.org>2019-08-26 00:46:01 +0200
commit4632df3c8308413cae8f39c12adcdd62eb1dfcb0 (patch)
tree5e14136da500534100fd6d44fec853204fdb4026
parented87ed55d5ff28c8560a0a2b59e6d68e7582210a (diff)
Update debian/rules to use override targets instead of sequence control options for dh (Closes: #932525).debian/1.5.0_rc1-1.2archive/debian/1.5.0_rc1-1.2
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules26
2 files changed, 10 insertions, 24 deletions
diff --git a/debian/changelog b/debian/changelog
index 2d274a6..48ae662 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+adns (1.5.0~rc1-1.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Update debian/rules to use override targets instead of sequence
+ control options for dh (Closes: #932525).
+
+ -- Magnus Holmgren <holmgren@debian.org> Mon, 26 Aug 2019 00:45:44 +0200
+
adns (1.5.0~rc1-1.1) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/rules b/debian/rules
index db6bee2..da7cbbb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,31 +10,9 @@ export XLDFLAGS=$(shell dpkg-buildflags --get LDFLAGS)
%:
dh $@
-build: build-stamp
-build-stamp:
- dh build --before configure
- dh_auto_configure
- dh_auto_build
-ifeq ($(filter nocheck,$(DEB_BUILD_OPTIONS)),)
- make -C regress check
-endif
- dh build --after test
- touch $@
-
-clean:
- dh clean --before dh_auto_clean
+override_dh_auto_clean:
-$(MAKE) distclean
- -$(MAKE) -C regress distclean
rm -f regress/output-*
- dh clean --after dh_auto_clean
-install: build
- dh install --before dh_auto_install
+override_dh_auto_install:
$(MAKE) install prefix=`pwd`/debian/tmp/usr
- dh install --after dh_auto_install
-
-binary-arch: build install
- dh binary-arch
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install