summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2014-10-20 14:55:45 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2014-10-20 15:52:47 +0100
commit75f9dcf6b6d0b55b688c427bfd9b62c19c187bac (patch)
treedcd8949f75ee8369a1c89bae3a2069d50fd1e03d
parent45133e2d3ed02c47cf20765bc95a78c5c1da354d (diff)
Add -dbg package.
-rw-r--r--debian/changelog1
-rw-r--r--debian/control14
-rwxr-xr-xdebian/rules3
3 files changed, 18 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8c46d31..dc8955c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,7 @@ adns (1.5.0~rc0-0~exp1~) experimental; urgency=low
* In symbols file: ignore all symbols `adns__*' with a regex rule.
* Remove obsolete emacs local variables stanza from debian/changelog.
* Add dh and debian files to .gitignore.
+ * Add -dbg package. Closes: #489301.
--
diff --git a/debian/control b/debian/control
index 2366752..98e87c0 100644
--- a/debian/control
+++ b/debian/control
@@ -48,3 +48,17 @@ Description: Asynchronous-capable DNS client library
any DNS data formats. Many queries can be handled simultaneously.
.
This package contains the runtime library.
+
+Package: libadns1-dbg
+Section: debug
+Architecture: any
+Depends: libadns1 (= ${binary:Version}), ${misc:Depends}
+Description: Asynchronous-capable DNS client library (debugging symbols)
+ adns is a resolver library for C (and C++) programs. In contrast
+ with the existing interfaces, gethostbyname et al and libresolv, it
+ can be used in an asynchronous, non-blocking manner, and has a
+ convenient interface which doesn't require the application to handle
+ any DNS data formats. Many queries can be handled simultaneously.
+ .
+ This package contains the debugging symbols associated with libadns1,
+ for debugging adns and programs that use it.
diff --git a/debian/rules b/debian/rules
index b8350aa..8a66dfe 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,8 @@
#!/usr/bin/make -f
#export DH_VERBOSE=1
+
+export DH_OPTIONS += --dbg-package=libadns1-dbg
+
%:
dh $@