summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2014-10-20 16:34:52 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2014-10-20 16:39:39 +0100
commitf29e7003361bb2b93f7de60198214c612ae55cd4 (patch)
treefb2f38a581475724fa1e94ddf53f3477c5ab3666
parent208ad764f9454fd39d575ad82945906f60961282 (diff)
Build system: Bodge regress/Makefile.in's .SECONDARY some more
The declaration mentioning CLIENTS has an unfortunate side-effect: it `mentions' the file adnshost_c.o, which is not part of the build and is not buildable. According to the rules in `(make)Implicit Rule Search' this causes make to try to build adnshost_playback from adnshost_c.o (rule 5). This is because files whose names are `mentioned' are taken to `ought to exist'. This causes adns to be unbuildable on the make from Debian sid (4.0-8); it is not visible on earlier makes (eg 3.81-8.2) because they don't appear to actually follow the documented algorithm. Bodge this (further) by filtering adnshost out of the client list. It is currently the only client made out of multiple object files. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog3
-rw-r--r--regress/Makefile.in2
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 1785ba7..9e60037 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,8 +11,9 @@ adns (1.5.0~rc0-0~exp1) experimental; urgency=low
* Remove values from rcsids, to remove diffs from upstream.
* Add ${misc:Depends} to quieten lintian (no change to the .debs).
* Support dpkg-buildflags (ie, build with hardening).
+ * Patch regress/Makefile.in to fix problem with .SECONDARY declaration.
- -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 20 Oct 2014 16:12:38 +0100
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 20 Oct 2014 16:34:44 +0100
adns (1.4-2) unstable; urgency=low
diff --git a/regress/Makefile.in b/regress/Makefile.in
index 2834e83..34be146 100644
--- a/regress/Makefile.in
+++ b/regress/Makefile.in
@@ -56,7 +56,7 @@ LINK_CMD= $(CC) $(LDFLAGS) $^ $(LDLIBS) -o $@
%_playback: %_c.o hplayback.o $(HARNLOBJS)
$(LINK_CMD)
-.SECONDARY: $(addsuffix _c.o, $(CLIENTS))
+.SECONDARY: $(addsuffix _c.o, $(filter-out adnshost, $(CLIENTS)))
# Without this, make will remove <client>_c.o after building <client>.
# This wastes effort. (Debian bug #4073.)
#