summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorian <ian>2000-09-14 01:23:39 +0000
committerian <ian>2000-09-14 01:23:39 +0000
commit5a0be2445e09e1d0fc6ae995b6c0296bc28e657d (patch)
tree80034894180d6b4961c6e7138749720f9f7f4284 /configure.in
parente32d0f9ec3413e4781ef9682e360e3c31e41c293 (diff)
+ Bugfixes:
@@ -1,10 +1,24 @@ adns (0.10) unstable; urgency=low - * Add list of tested platforms in INSTALL file. + Bugfixes: + * Actually compile shared libraries by default ! + + Portability fixes: * Fix <sys/fcntl.h> in client/adnsresfilter.c to <fcntl.h>. - * Kill bogus warning, adh-main.c: `arg2' might be used uninitialized ... * #include <sys/types.h> and <unistd.h> for fcntl in */*.c. + * Cope with compilers that don't do `inline'. + * Do not use variadic macro, use stdarg instead (adnslogres.c). + * #include "config.h" before "adns.h". + * adnstest: setvbuf(stdout,...) before we do first output. + * Cast a sizeof(...) in src/event.c to unsigned long before printing. + * #include <sys/select.h> if it exists. + + Portability cleanups: + * Add list of tested platforms in INSTALL file. + * Kill bogus warning, adh-main.c: `arg2' might be used uninitialized ... * Add extra {...} near adnslogres.c:167 to kill spurious warning. + * Use `printf' instead of `echo -n'. + --
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 208e94a..10395c6 100644
--- a/configure.in
+++ b/configure.in
@@ -24,6 +24,21 @@
AC_INIT(src/adns.h)
AC_CONFIG_HEADER(src/config.h)
+dnl DPKG_CACHED_TRY_COMPILE(<description>,<cachevar>,<include>,<program>,<ifyes>,<ifno>)
+define(DPKG_CACHED_TRY_COMPILE,[
+ AC_MSG_CHECKING($1)
+ AC_CACHE_VAL($2,[
+ AC_TRY_COMPILE([$3],[$4],[$2=yes],[$2=no])
+ ])
+ if test "x$$2" = xyes; then
+ true
+ $5
+ else
+ true
+ $6
+ fi
+])
+
AC_MSG_CHECKING(whether you requested dynamic linking)
AC_SUBST(ENABLE_DYNAMIC)
AC_ARG_ENABLE(dynamic,
@@ -42,7 +57,7 @@ AC_ARG_ENABLE(dynamic,
;;
esac
],[
- ENABLE_DYNAMIC=yes
+ ENABLE_DYNAMIC=elf
AC_MSG_RESULT([yes, by default])
])
@@ -91,7 +106,14 @@ ADNS_C_GETFUNC(inet_aton,resolv,[
AC_MSG_WARN([inet_aton is in libresolv, urgh. Must use -lresolv.])
])
+DPKG_CACHED_TRY_COMPILE(inlines,dpkg_cv_c_inline,,
+ [} inline int foo (int x) {],
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_INLINE),
+ AC_MSG_RESULT(no))
+
ADNS_C_GCCATTRIB
+AC_CHECK_HEADERS(sys/select.h)
AC_SUBST(WARNS)