summaryrefslogtreecommitdiff
path: root/dynamic
diff options
context:
space:
mode:
authorian <ian>1998-11-29 19:09:24 +0000
committerian <ian>1998-11-29 19:09:24 +0000
commit1c957fdadf0ab368ab1266fbd6a9ea8fbe3b271d (patch)
treef03cd7f242854b0e25b672619faccf99d068c985 /dynamic
parent12c5b204145993a34b92ac2b7de5ebcebb6d2d15 (diff)
Regression tests run, first one written.
Diffstat (limited to 'dynamic')
-rw-r--r--dynamic/.cvsignore1
-rw-r--r--dynamic/Makefile37
-rw-r--r--dynamic/Makefile.in37
3 files changed, 75 insertions, 0 deletions
diff --git a/dynamic/.cvsignore b/dynamic/.cvsignore
new file mode 100644
index 0000000..31cab98
--- /dev/null
+++ b/dynamic/.cvsignore
@@ -0,0 +1 @@
+libadns.so.*
diff --git a/dynamic/Makefile b/dynamic/Makefile
new file mode 100644
index 0000000..e617bc4
--- /dev/null
+++ b/dynamic/Makefile
@@ -0,0 +1,37 @@
+# dynamic/Makefile - dynamic library Makefile
+#
+# This file is part of adns, which is Copyright (C) 1997, 1998 Ian Jackson
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+TARGETS= $(LIBFILE)
+
+include ../settings.make
+include ../src/adns.make
+
+ALLOBJS= $(addsuffix _p.o, $(basename $(LIBOBJS)))
+
+install:
+ $(INSTALL_LIB) $(LIBFILE) $(lib_dir)
+ $(INSTALL_HDR) ../src/adns.h $(include_dir)
+
+$(LIBFILE): $(ALLOBJS)
+ rm -f $@
+ $(CC) -shared -Wxl,soname=libadns.so.$(MAJOR) -o $@ $(ALLOBJS) -lc
+
+%_p.o: ../src/%.c ../src/adns.h ../src/internal.h
+ $(CC) -fpic -I../src -c -o $@ $<
+
+$(LIBOBJS):
diff --git a/dynamic/Makefile.in b/dynamic/Makefile.in
new file mode 100644
index 0000000..e617bc4
--- /dev/null
+++ b/dynamic/Makefile.in
@@ -0,0 +1,37 @@
+# dynamic/Makefile - dynamic library Makefile
+#
+# This file is part of adns, which is Copyright (C) 1997, 1998 Ian Jackson
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+TARGETS= $(LIBFILE)
+
+include ../settings.make
+include ../src/adns.make
+
+ALLOBJS= $(addsuffix _p.o, $(basename $(LIBOBJS)))
+
+install:
+ $(INSTALL_LIB) $(LIBFILE) $(lib_dir)
+ $(INSTALL_HDR) ../src/adns.h $(include_dir)
+
+$(LIBFILE): $(ALLOBJS)
+ rm -f $@
+ $(CC) -shared -Wxl,soname=libadns.so.$(MAJOR) -o $@ $(ALLOBJS) -lc
+
+%_p.o: ../src/%.c ../src/adns.h ../src/internal.h
+ $(CC) -fpic -I../src -c -o $@ $<
+
+$(LIBOBJS):