summaryrefslogtreecommitdiff
path: root/regress/Makefile.in
diff options
context:
space:
mode:
authorMark Wooding <mdw@distorted.org.uk>2014-04-26 14:22:11 +0100
committerMark Wooding <mdw@distorted.org.uk>2014-06-09 20:58:07 +0100
commit2dee2b7a71c858a78d06814eb98f23ede5602e37 (patch)
tree805b571466e594e7e74bd69f32ab39935bf877f7 /regress/Makefile.in
parent7704b73af964218a7d9541e33f640b1261b6a9c9 (diff)
Hacking to make out-of-tree builds work properly.
This is mostly standard. The regression-test scripts have had an interface enhancement: they will look for source-like files using the $srcdir environment variable, which defaults to `.' for compatibility. Signed-off-by: Mark Wooding <mdw@distorted.org.uk>
Diffstat (limited to 'regress/Makefile.in')
-rw-r--r--regress/Makefile.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/regress/Makefile.in b/regress/Makefile.in
index d41cf29..7428965 100644
--- a/regress/Makefile.in
+++ b/regress/Makefile.in
@@ -28,10 +28,10 @@ PROGS_SYSDEP= @PROGS_HAVE_TSEARCH@
CLIENTS= adnstest adnshost adnslogres $(PROGS_SYSDEP)
AUTOCHDRS= harness.h hsyscalls.h hredirect.h
AUTOCSRCS= hrecord.c hplayback.c hcommon.c
-include $(srcdir)/../settings.make
+include ../settings.make
include $(srcdir)/../src/adns.make
-DIRCFLAGS= -I$(srcdir)/../src
+DIRCFLAGS= -I../src -I$(srcdir) -I$(srcdir)/../src
HCPPFLAGS= -DADNS_REGRESS_TEST -I.
@@ -46,7 +46,7 @@ ALL_OBJS= $(HARNLOBJS) dtest.o hrecord.o hplayback.o
all install uninstall: $(TARGETS)
check: $(TARGETS)
- ./checkall
+ srcdir=$(srcdir) $(srcdir)/checkall
LINK_CMD= $(CC) $(LDFLAGS) $^ $(LDLIBS) -o $@
@@ -70,6 +70,6 @@ $(ALL_OBJS): harness.h hsyscalls.h
$(ADH_OBJS): $(srcdir)/../client/adnshost.h
%:: %.m4 hmacros.i4 hsyscalls.i4
- $(M4) -P $< >$@-a.new
+ $(M4) -P -I$(srcdir) $< >$@-a.new
sed -e 's/hm_comma/,/g; s/hm_squote/'\''/g; /^[ ]*$$/d' <$@-a.new >$@-b.new
- @mv -f $@-b.new $@; rm -f $@-a.new
+ @mv -f $@-b.new $(srcdir)/$@; rm -f $@-a.new