summaryrefslogtreecommitdiff
path: root/regress
diff options
context:
space:
mode:
authorian <ian>2000-09-16 22:26:05 +0000
committerian <ian>2000-09-16 22:26:05 +0000
commita069d77f2601cbaf8a6eca34e0af656c7f39ae9e (patch)
treecd443ffeb422e307dc48089ffc0ad4ebc02bcb01 /regress
parentf9476535903f0225fba0733203580c88b30ad6a1 (diff)
Do not run tests of executables not built. Do not build
adnsresfilter_record/playback. Add missing #include <sys/time.h>, <time.h>
Diffstat (limited to 'regress')
-rw-r--r--regress/Makefile.in4
-rw-r--r--regress/hplayback.c1
-rw-r--r--regress/hplayback.c.m41
-rwxr-xr-xregress/r1test16
4 files changed, 17 insertions, 5 deletions
diff --git a/regress/Makefile.in b/regress/Makefile.in
index 5da4e28..3a40a68 100644
--- a/regress/Makefile.in
+++ b/regress/Makefile.in
@@ -24,7 +24,9 @@
srcdir= @srcdir@
VPATH= @srcdir@
-CLIENTS= adnstest adnshost adnslogres adnsresfilter
+PROGS_SYSDEP= @PROGS_HAVE_TSEARCH@
+
+CLIENTS= adnstest adnshost adnslogres $(PROGS_SYSDEP)
AUTOCHDRS= harness.h hsyscalls.h hredirect.h
AUTOCSRCS= hrecord.c hplayback.c hcommon.c
include $(srcdir)/../settings.make
diff --git a/regress/hplayback.c b/regress/hplayback.c
index 92570ff..fdb3a7d 100644
--- a/regress/hplayback.c
+++ b/regress/hplayback.c
@@ -6,6 +6,7 @@
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
+#include <sys/time.h>
#include <unistd.h>
#include <fcntl.h>
#include "harness.h"
diff --git a/regress/hplayback.c.m4 b/regress/hplayback.c.m4
index 39f409c..4c8fb4d 100644
--- a/regress/hplayback.c.m4
+++ b/regress/hplayback.c.m4
@@ -34,6 +34,7 @@ m4_include(hmacros.i4)
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
+#include <sys/time.h>
#include <unistd.h>
#include <fcntl.h>
diff --git a/regress/r1test b/regress/r1test
index a325600..8f0c411 100755
--- a/regress/r1test
+++ b/regress/r1test
@@ -56,10 +56,18 @@ else
exec </dev/null
fi
+playback=./${program}_playback
+if test ! -f $playback
+then
+ printf "SKIPPED-$casename "
+ mrc=5
+ exit
+fi
+
set +e
-ADNS_TEST_REPORT_FD=3 3>>"$ocase.report" >"$ocase.out" 2>"$ocase.err" \
-ADNS_TEST_IN_FD=4 \
- ./${program}_playback $initflags"$initstring" $queryargs
+ADNS_TEST_REPORT_FD=3 ADNS_TEST_IN_FD=4 \
+ 3>>"$ocase.report" >"$ocase.out" 2>"$ocase.err" \
+ $playback $initflags"$initstring" $queryargs
rc=$?
set -e
@@ -83,7 +91,7 @@ do
fi
done
-cat >"$ocase.leftover"
+cat <&4 >"$ocase.leftover"
if egrep . /dev/null "$ocase.leftover"
then
failwhy="$failwhy EXITED EARLY"