summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2015-12-14 20:52:48 +0100
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2015-12-14 20:58:14 +0100
commit5fb57ce34fe5143b473131ce3b7821a2458918a1 (patch)
tree919317c0baf7d1dc6899ceb0f89bbb4732f4b009 /debian/patches
parent38a56a963bff6b612f4a3f96c53fac8492e40eea (diff)
Imported Debian patch 12.10.0-1
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/01-pkgconfig_fixes.patch22
-rw-r--r--debian/patches/02-generated_sources_path.patch16
-rw-r--r--debian/patches/03-ac_config_macro_dir.patch23
-rw-r--r--debian/patches/series3
4 files changed, 64 insertions, 0 deletions
diff --git a/debian/patches/01-pkgconfig_fixes.patch b/debian/patches/01-pkgconfig_fixes.patch
new file mode 100644
index 0000000..e045a7e
--- /dev/null
+++ b/debian/patches/01-pkgconfig_fixes.patch
@@ -0,0 +1,22 @@
+Description: Fix a few things in pkgconfig file
+Author: Thanh Tung Nguyen <thngtong@gmailcom>
+Forwarded: no
+Last-Update: 2013-12-11
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/appindicator3-sharp-0.1.pc.in
++++ b/appindicator3-sharp-0.1.pc.in
+@@ -1,9 +1,12 @@
+ prefix=@prefix@
+ exec_prefix=${prefix}
+ libdir=@libdir@
++pkglibdir=${exec_prefix}/lib/cli/@ASSEMBLY_PC@
++gapidir=${exec_prefix}/share/gapi-3.0
+
+ Name: @ASSEMBLY_TITLE@
+ Description: @ASSEMBLY_DESCRIPTION@
+ Version: @VERSION@
+ Requires:
+-Libs: -r:${libdir}/mono/@ASSEMBLY_NAME@/@ASSEMBLY_NAME@.dll
++Libs: -r:${pkglibdir}/@ASSEMBLY_NAME@.dll
++Cflags: -I:${gapidir}/@ASSEMBLY_NAME@-api.xml
diff --git a/debian/patches/02-generated_sources_path.patch b/debian/patches/02-generated_sources_path.patch
new file mode 100644
index 0000000..9432fe3
--- /dev/null
+++ b/debian/patches/02-generated_sources_path.patch
@@ -0,0 +1,16 @@
+Description: Fix generated code path
+Author: Thanh Tung Nguyen <thngtong@gmail.com>
+Last-Update: 2015-01-18
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/sources/Makefile.am
++++ b/sources/Makefile.am
+@@ -42,7 +42,7 @@
+
+ $(DLL): $(build_sources) generated-stamp
+ $(CSC) -nowarn:169 -unsafe -target:library $(GTK_SHARP_LIBS) \
+- $(build_sources) generated/*.cs -out:$(DLL)
++ $(build_sources) generated/*/*.cs -out:$(DLL)
+
+ install-data-local:
+ echo "$(GACUTIL) /i $(DLL) /f $(GACUTIL_FLAGS)"; \
diff --git a/debian/patches/03-ac_config_macro_dir.patch b/debian/patches/03-ac_config_macro_dir.patch
new file mode 100644
index 0000000..91868cd
--- /dev/null
+++ b/debian/patches/03-ac_config_macro_dir.patch
@@ -0,0 +1,23 @@
+Description: Add correctly the local macro directory
+Author: Thanh Tung Nguyen <thngtong@gmail.com>
+Last-Updated: 2013-11-02
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,7 +16,7 @@
+ ASSEMBLY_SHORTNAME="appindicator3"
+ ASSEMBLY_TITLE="AppIndicator3#"
+ ASSEMBLY_VERSION="12.10.0"
+-AC_SUBST([ACLOCAL_AMFLAGS], ["-I m4 \${ACLOCAL_FLAGS}"])
++AC_CONFIG_MACRO_DIR([m4])
+
+ AC_SUBST(ASSEMBLY_NAME)
+ AC_SUBST(ASSEMBLY_VERSION)
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,3 +1,5 @@
++ACLOCAL_AMFLAGS = -I m4
++
+ SUBDIRS = sources sources/glue doc
+
+ pkgconfigdir = $(libdir)/pkgconfig
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..5ebea47
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+01-pkgconfig_fixes.patch
+02-generated_sources_path.patch
+03-ac_config_macro_dir.patch