summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2015-12-14 20:52:48 +0100
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2015-12-14 20:58:14 +0100
commit5fb57ce34fe5143b473131ce3b7821a2458918a1 (patch)
tree919317c0baf7d1dc6899ceb0f89bbb4732f4b009 /debian/rules
parent38a56a963bff6b612f4a3f96c53fac8492e40eea (diff)
Imported Debian patch 12.10.0-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e58e75f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed
+
+CONFIG=--prefix=/usr --libdir=/usr/lib
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf stamp-h sources/generated/*
+
+override_dh_auto_configure:
+ dh_auto_configure --parallel -- $(CONFIG)
+
+override_dh_auto_install:
+ dh_auto_install --parallel --destdir=$(CURDIR)/debian/tmp
+
+override_dh_makeshlibs:
+ dh_makeshlibs -n -plibappindicator3-0.1-cil
+ dh_makeshlibs --remaining-packages
+
+%:
+ dh $@ --parallel --with autoreconf --with cli