summaryrefslogtreecommitdiff
path: root/sources/glue
diff options
context:
space:
mode:
authorAndrew Shadura <andrew.shadura@collabora.co.uk>2015-12-14 20:57:36 +0100
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2015-12-14 20:57:36 +0100
commit38a56a963bff6b612f4a3f96c53fac8492e40eea (patch)
tree221578f82fa010f53358d963995f7f29182c3ba7 /sources/glue
Imported Upstream version 12.10.0
Diffstat (limited to 'sources/glue')
-rw-r--r--sources/glue/Makefile.am18
-rw-r--r--sources/glue/generated.c13
2 files changed, 31 insertions, 0 deletions
diff --git a/sources/glue/Makefile.am b/sources/glue/Makefile.am
new file mode 100644
index 0000000..f1d14f0
--- /dev/null
+++ b/sources/glue/Makefile.am
@@ -0,0 +1,18 @@
+lib_LTLIBRARIES = libappindicator3sharpglue-12.10.0.la
+
+libappindicator3sharpglue_12_10_0_la_SOURCES =
+
+nodist_libappindicator3sharpglue_12_10_0_la_SOURCES = generated.c
+
+libappindicator3sharpglue_12_10_0_la_LDFLAGS = -module -avoid-version -no-undefined
+
+libappindicator3sharpglue_12_10_0_la_LIBADD = $(APPINDICATOR3_LIBS)
+
+INCLUDES = $(APPINDICATOR3_CFLAGS) -I$(top_srcdir)
+
+libappindicator3sharpglue.dll: $(libappindicator3sharpglue_12_10_0_la_OBJECTS) libappindicator3sharpglue.rc libappindicator3sharpglue.def
+ ./build-dll libappindicator3sharpglue $(VERSION)
+
+CLEANFILES = lib*.a lib*.dll
+
+EXTRA_DIST =
diff --git a/sources/glue/generated.c b/sources/glue/generated.c
new file mode 100644
index 0000000..98c1fc5
--- /dev/null
+++ b/sources/glue/generated.c
@@ -0,0 +1,13 @@
+// This file was generated by the Gtk# code generator.
+// Any changes made will be lost if regenerated.
+
+#include <libappindicator/app-indicator.h>
+
+guint appindicator3sharp_appindicator3_indicator_get_parent_offset (void);
+
+guint
+appindicator3sharp_appindicator3_indicator_get_parent_offset (void)
+{
+ return (guint)G_STRUCT_OFFSET (AppIndicator, parent);
+}
+