summaryrefslogtreecommitdiff
path: root/sources
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2015-12-21 11:06:08 +0100
committerAndrew Shadura <andrewsh@debian.org>2015-12-21 11:06:08 +0100
commit525bdd775ca784a06f9d6828c8c4dab21175111b (patch)
tree1fb8a952d52791e2b3b0c4d0b4562f72190fa7ed /sources
parent38a56a963bff6b612f4a3f96c53fac8492e40eea (diff)
Imported Upstream version 12.10.0+git20151221
Diffstat (limited to 'sources')
-rw-r--r--sources/Makefile.am6
-rw-r--r--sources/glue/Makefile.am4
-rw-r--r--sources/glue/generated.c13
3 files changed, 6 insertions, 17 deletions
diff --git a/sources/Makefile.am b/sources/Makefile.am
index 2881239..50e0fe2 100644
--- a/sources/Makefile.am
+++ b/sources/Makefile.am
@@ -13,9 +13,9 @@ sources =
build_sources = AssemblyInfo.cs $(sources)
-CLEANFILES = $(DLL) generated-stamp generated/*.cs $(API)
+CLEANFILES = $(DLL) generated-stamp generated/*/*.cs $(API)
-DISTCLEANFILES = AssemblyInfo.cs $(DLLMAP)
+DISTCLEANFILES = AssemblyInfo.cs
noinst_DATA = $(DLL)
@@ -42,7 +42,7 @@ generated-stamp: $(API)
$(DLL): $(build_sources) generated-stamp
$(CSC) -nowarn:169 -unsafe -target:library $(GTK_SHARP_LIBS) \
- $(build_sources) generated/*.cs -out:$(DLL)
+ $(build_sources) generated/*/*.cs -out:$(DLL)
install-data-local:
echo "$(GACUTIL) /i $(DLL) /f $(GACUTIL_FLAGS)"; \
diff --git a/sources/glue/Makefile.am b/sources/glue/Makefile.am
index f1d14f0..aba7ffa 100644
--- a/sources/glue/Makefile.am
+++ b/sources/glue/Makefile.am
@@ -8,11 +8,13 @@ libappindicator3sharpglue_12_10_0_la_LDFLAGS = -module -avoid-version -no-undefi
libappindicator3sharpglue_12_10_0_la_LIBADD = $(APPINDICATOR3_LIBS)
-INCLUDES = $(APPINDICATOR3_CFLAGS) -I$(top_srcdir)
+AM_CPPFLAGS = $(APPINDICATOR3_CFLAGS) -I$(top_srcdir)
libappindicator3sharpglue.dll: $(libappindicator3sharpglue_12_10_0_la_OBJECTS) libappindicator3sharpglue.rc libappindicator3sharpglue.def
./build-dll libappindicator3sharpglue $(VERSION)
CLEANFILES = lib*.a lib*.dll
+DISTCLEANFILES = $(nodist_libappindicator3sharpglue_12_10_0_la_SOURCES)
+
EXTRA_DIST =
diff --git a/sources/glue/generated.c b/sources/glue/generated.c
deleted file mode 100644
index 98c1fc5..0000000
--- a/sources/glue/generated.c
+++ /dev/null
@@ -1,13 +0,0 @@
-// This file was generated by the Gtk# code generator.
-// Any changes made will be lost if regenerated.
-
-#include <libappindicator/app-indicator.h>
-
-guint appindicator3sharp_appindicator3_indicator_get_parent_offset (void);
-
-guint
-appindicator3sharp_appindicator3_indicator_get_parent_offset (void)
-{
- return (guint)G_STRUCT_OFFSET (AppIndicator, parent);
-}
-