summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/03-parallel_mdoc.patch26
-rw-r--r--debian/patches/series1
-rw-r--r--doc/Makefile.am7
3 files changed, 30 insertions, 4 deletions
diff --git a/debian/patches/03-parallel_mdoc.patch b/debian/patches/03-parallel_mdoc.patch
new file mode 100644
index 0000000..a75e05e
--- /dev/null
+++ b/debian/patches/03-parallel_mdoc.patch
@@ -0,0 +1,26 @@
+Author: Andrew Shadura <andrewsh@debian.org>
+Description: Don't run things twice.
+
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -15,9 +15,6 @@
+ update:
+ $(MDOC) update --out=en $(ASSEMBLIES)
+
+-$(srcdir)/en/*/*.xml $(srcdir)/en/*.xml:
+- $(MDOC) update --out=en $(ASSEMBLIES)
+-
+ $(ASSEMBLY_NAME)-docs.source:
+ @echo "Generating $@"
+ @echo "<?xml version=\"1.0\"?>" > $@
+@@ -25,7 +22,9 @@
+ @echo " <source provider=\"ecma\" basefile=\"$(ASSEMBLY_NAME)-docs\" path=\"classlib-$(ASSEMBLY_SHORTNAME)\"/>" >> $@
+ @echo "</monodoc>" >> $@
+
+-$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: $(srcdir)/en/*/*.xml $(srcdir)/en/*.xml
++$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: assemble
++
++assemble: update
+ $(MDASSEMBLER) --ecma $(srcdir)/en -o $(ASSEMBLY_NAME)-docs
+
+ CLEANFILES = $(TARGETS)
diff --git a/debian/patches/series b/debian/patches/series
index e6e4d3a..9b2a90b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
01-pkgconfig_fixes.patch
02-dllmap_fix.patch
+03-parallel_mdoc.patch
diff --git a/doc/Makefile.am b/doc/Makefile.am
index bd19464..6ba455a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -15,9 +15,6 @@ all: $(TARGETS)
update:
$(MDOC) update --out=en $(ASSEMBLIES)
-$(srcdir)/en/*/*.xml $(srcdir)/en/*.xml:
- $(MDOC) update --out=en $(ASSEMBLIES)
-
$(ASSEMBLY_NAME)-docs.source:
@echo "Generating $@"
@echo "<?xml version=\"1.0\"?>" > $@
@@ -25,7 +22,9 @@ $(ASSEMBLY_NAME)-docs.source:
@echo " <source provider=\"ecma\" basefile=\"$(ASSEMBLY_NAME)-docs\" path=\"classlib-$(ASSEMBLY_SHORTNAME)\"/>" >> $@
@echo "</monodoc>" >> $@
-$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: $(srcdir)/en/*/*.xml $(srcdir)/en/*.xml
+$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: assemble
+
+assemble: update
$(MDASSEMBLER) --ecma $(srcdir)/en -o $(ASSEMBLY_NAME)-docs
CLEANFILES = $(TARGETS)