summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 21 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 1edd14f..0055d17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ ASSEMBLY_PC="appindicator3-sharp-0.1"
ASSEMBLY_SHORTNAME="appindicator3"
ASSEMBLY_TITLE="AppIndicator3#"
ASSEMBLY_VERSION="12.10.0"
-AC_SUBST([ACLOCAL_AMFLAGS], ["-I m4 \${ACLOCAL_FLAGS}"])
+AC_CONFIG_MACRO_DIR([m4])
AC_SUBST(ASSEMBLY_NAME)
AC_SUBST(ASSEMBLY_VERSION)
@@ -30,21 +30,21 @@ AC_SUBST(ASSEMBLY_PC)
dnl Check for pkg-config
AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
-if test "x$PKG_CONFIG" = "xno"; then
+if test "$PKG_CONFIG" = "no"; then
AC_MSG_ERROR(['pkg-config' is not in your PATH.])
fi
dnl Check for Mono
PKG_CHECK_MODULES(MONO_DEPENDENCY, mono >= 1.0, has_mono=true, has_mono=false)
-if test "x$has_mono" = "xtrue"; then
-1 AC_PATH_PROG(RUNTIME, mono, no)
- AC_PATH_PROG(CSC, gmcs, no)
+if test "$has_mono" = "true"; then
+ AC_PATH_PROG(RUNTIME, mono, no)
+ AC_PATH_PROG(CSC, mcs, no)
LIB_PREFIX=.so
LIB_SUFFIX=
else
AC_PATH_PROG(CSC, csc.exe, no)
- if test x$CSC = "xno"; then
+ if test "$CSC" = "no"; then
AC_MSG_ERROR([You need to install either mono or .Net])
else
RUNTIME=
@@ -54,17 +54,17 @@ else
fi
CS="C#"
-if test "x$CSC" = "xno" ; then
+if test "$CSC" = "no" ; then
AC_MSG_ERROR([No $CS compiler found])
fi
AC_PATH_PROG(GACUTIL, gacutil, no)
-if test "x$GACUTIL" = "xno" ; then
+if test "$GACUTIL" = "no" ; then
AC_MSG_ERROR([No gacutil tool found])
fi
GACUTIL_FLAGS="/package $ASSEMBLY_NAME /root "'$(DESTDIR)$(prefix)/lib'
-
+
AC_SUBST(RUNTIME)
AC_SUBST(CSC)
AC_SUBST(GACUTIL)
@@ -83,10 +83,10 @@ AC_SUBST(GAPIXMLDIR)
dnl Check for gapi
AC_PATH_PROG(GAPI_PARSER, gapi3-parser, no)
-if test "x$GAPI_PARSER" = "xno"; then
+if test "$GAPI_PARSER" = "no"; then
AC_MSG_CHECKING(for gapi3-parser.exe)
GAPI_PARSER=`which gapi3-parser.exe 2> /dev/null`
- if test "x$GAPI_PARSER" = "xno" ; then
+ if test "$GAPI_PARSER" = "no" ; then
AC_MSG_ERROR(['gapi3_parser'/'gapi3-parser.exe' not found.])
fi
AC_MSG_RESULT($GAPI_PARSER)
@@ -95,10 +95,10 @@ fi
AC_SUBST(GAPI_PARSER)
AC_PATH_PROG(GAPI_FIXUP, gapi3-fixup, no)
-if test "x$GAPI_FIXUP" = "xno"; then
+if test "$GAPI_FIXUP" = "no"; then
AC_MSG_CHECKING(for gapi3-fixup.exe)
GAPI_FIXUP=`which gapi3-fixup.exe 2> /dev/null`
- if test "x$GAPI_FIXUP" = "xno" ; then
+ if test "$GAPI_FIXUP" = "no" ; then
AC_MSG_ERROR(['gapi3_fixup'/'gapi3-fixup.exe' not found.])
fi
AC_MSG_RESULT($GAPI_FIXUP)
@@ -107,10 +107,10 @@ fi
AC_SUBST(GAPI_FIXUP)
AC_PATH_PROG(GAPI_CODEGEN, gapi3-codegen, no)
-if test "x$GAPI_CODEGEN" = "xno"; then
+if test "$GAPI_CODEGEN" = "no"; then
AC_MSG_CHECKING(for gapi3_codegen.exe)
GAPI_CODEGEN=`which gapi3_codegen.exe 2> /dev/null`
- if test "x$GAPI_CODEGEN" = "xno" ; then
+ if test "$GAPI_CODEGEN" = "no" ; then
AC_MSG_ERROR(['gapi3-codegen'/'gapi3_codegen.exe' not found.])
fi
AC_MSG_RESULT([$GAPI_CODEGEN])
@@ -120,8 +120,9 @@ AC_SUBST(GAPI_CODEGEN)
dnl Check for monodoc
AC_PATH_PROG(MDASSEMBLER, mdassembler, no)
-AC_PATH_PROG(MONODOCER, monodocer, no)
-if test "x$MONODOCER" = "xno" -o "x$MDASSEMBLER" = "xno"; then
+AC_PATH_PROG(MDOC, mdoc, no)
+if test "$MDOC" = "no" -o "$MDASSEMBLER" = "no"
+then
enable_monodoc=no
doc_sources_dir=
else
@@ -129,9 +130,9 @@ else
doc_sources_dir="`pkg-config --variable=sourcesdir monodoc`"
fi
AC_SUBST(MDASSEMBLER)
-AC_SUBST(MONODOCER)
+AC_SUBST(MDOC)
-AM_CONDITIONAL(ENABLE_MONODOC, test "x$enable_monodoc" = "xyes")
+AM_CONDITIONAL(ENABLE_MONODOC, test "$enable_monodoc" = "yes")
dnl Check for AppIndicator3
PKG_CHECK_MODULES(APPINDICATOR3, appindicator3-0.1)
appindicator3_prefix=/usr
@@ -158,5 +159,5 @@ echo "---------------------"
echo ""
echo " * Installation prefix: $prefix"
echo " * compiler: $CSC"
-echo " * Documentation: ($MONODOC)"
+echo " * Documentation: ($enable_monodoc)"
echo ""