summaryrefslogtreecommitdiff
path: root/debian/patches/02-generated_sources_path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/02-generated_sources_path.patch')
-rw-r--r--debian/patches/02-generated_sources_path.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/patches/02-generated_sources_path.patch b/debian/patches/02-generated_sources_path.patch
new file mode 100644
index 0000000..9432fe3
--- /dev/null
+++ b/debian/patches/02-generated_sources_path.patch
@@ -0,0 +1,16 @@
+Description: Fix generated code path
+Author: Thanh Tung Nguyen <thngtong@gmail.com>
+Last-Update: 2015-01-18
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/sources/Makefile.am
++++ b/sources/Makefile.am
+@@ -42,7 +42,7 @@
+
+ $(DLL): $(build_sources) generated-stamp
+ $(CSC) -nowarn:169 -unsafe -target:library $(GTK_SHARP_LIBS) \
+- $(build_sources) generated/*.cs -out:$(DLL)
++ $(build_sources) generated/*/*.cs -out:$(DLL)
+
+ install-data-local:
+ echo "$(GACUTIL) /i $(DLL) /f $(GACUTIL_FLAGS)"; \