summaryrefslogtreecommitdiff
path: root/debian/patches/03-parallel_mdoc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/03-parallel_mdoc.patch')
-rw-r--r--debian/patches/03-parallel_mdoc.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/patches/03-parallel_mdoc.patch b/debian/patches/03-parallel_mdoc.patch
new file mode 100644
index 0000000..a75e05e
--- /dev/null
+++ b/debian/patches/03-parallel_mdoc.patch
@@ -0,0 +1,26 @@
+Author: Andrew Shadura <andrewsh@debian.org>
+Description: Don't run things twice.
+
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -15,9 +15,6 @@
+ update:
+ $(MDOC) update --out=en $(ASSEMBLIES)
+
+-$(srcdir)/en/*/*.xml $(srcdir)/en/*.xml:
+- $(MDOC) update --out=en $(ASSEMBLIES)
+-
+ $(ASSEMBLY_NAME)-docs.source:
+ @echo "Generating $@"
+ @echo "<?xml version=\"1.0\"?>" > $@
+@@ -25,7 +22,9 @@
+ @echo " <source provider=\"ecma\" basefile=\"$(ASSEMBLY_NAME)-docs\" path=\"classlib-$(ASSEMBLY_SHORTNAME)\"/>" >> $@
+ @echo "</monodoc>" >> $@
+
+-$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: $(srcdir)/en/*/*.xml $(srcdir)/en/*.xml
++$(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: assemble
++
++assemble: update
+ $(MDASSEMBLER) --ecma $(srcdir)/en -o $(ASSEMBLY_NAME)-docs
+
+ CLEANFILES = $(TARGETS)