summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e58e75f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed
+
+CONFIG=--prefix=/usr --libdir=/usr/lib
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf stamp-h sources/generated/*
+
+override_dh_auto_configure:
+ dh_auto_configure --parallel -- $(CONFIG)
+
+override_dh_auto_install:
+ dh_auto_install --parallel --destdir=$(CURDIR)/debian/tmp
+
+override_dh_makeshlibs:
+ dh_makeshlibs -n -plibappindicator3-0.1-cil
+ dh_makeshlibs --remaining-packages
+
+%:
+ dh $@ --parallel --with autoreconf --with cli