summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 6f9fc80..bd19464 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -10,15 +10,13 @@ endif
ASSEMBLIES = $(top_srcdir)/out/$(ASSEMBLY_NAME).dll
-UPDATE_ASSEMBLIES = $(addprefix -assembly:, $(ASSEMBLIES))
-
all: $(TARGETS)
update:
- $(MONODOCER) $(UPDATE_ASSEMBLIES) -path:en
+ $(MDOC) update --out=en $(ASSEMBLIES)
$(srcdir)/en/*/*.xml $(srcdir)/en/*.xml:
- $(MONODOCER) $(UPDATE_ASSEMBLIES) -path:en
+ $(MDOC) update --out=en $(ASSEMBLIES)
$(ASSEMBLY_NAME)-docs.source:
@echo "Generating $@"
@@ -31,6 +29,7 @@ $(ASSEMBLY_NAME)-docs.zip $(ASSEMBLY_NAME)-docs.tree: $(srcdir)/en/*/*.xml $(src
$(MDASSEMBLER) --ecma $(srcdir)/en -o $(ASSEMBLY_NAME)-docs
CLEANFILES = $(TARGETS)
+DISTCLEANFILES = $(srcdir)/en/*/*.xml $(srcdir)/en/*.xml
NAMESPACES=$(ASSEMBLY_NAMESPACE)