summaryrefslogtreecommitdiff
path: root/sources
diff options
context:
space:
mode:
Diffstat (limited to 'sources')
-rw-r--r--sources/Makefile.am4
-rw-r--r--sources/glue/Makefile.am4
-rw-r--r--sources/glue/generated.c13
3 files changed, 5 insertions, 16 deletions
diff --git a/sources/Makefile.am b/sources/Makefile.am
index 9f6dcc2..50e0fe2 100644
--- a/sources/Makefile.am
+++ b/sources/Makefile.am
@@ -13,9 +13,9 @@ sources =
build_sources = AssemblyInfo.cs $(sources)
-CLEANFILES = $(DLL) generated-stamp generated/*.cs $(API)
+CLEANFILES = $(DLL) generated-stamp generated/*/*.cs $(API)
-DISTCLEANFILES = AssemblyInfo.cs $(DLLMAP)
+DISTCLEANFILES = AssemblyInfo.cs
noinst_DATA = $(DLL)
diff --git a/sources/glue/Makefile.am b/sources/glue/Makefile.am
index f1d14f0..aba7ffa 100644
--- a/sources/glue/Makefile.am
+++ b/sources/glue/Makefile.am
@@ -8,11 +8,13 @@ libappindicator3sharpglue_12_10_0_la_LDFLAGS = -module -avoid-version -no-undefi
libappindicator3sharpglue_12_10_0_la_LIBADD = $(APPINDICATOR3_LIBS)
-INCLUDES = $(APPINDICATOR3_CFLAGS) -I$(top_srcdir)
+AM_CPPFLAGS = $(APPINDICATOR3_CFLAGS) -I$(top_srcdir)
libappindicator3sharpglue.dll: $(libappindicator3sharpglue_12_10_0_la_OBJECTS) libappindicator3sharpglue.rc libappindicator3sharpglue.def
./build-dll libappindicator3sharpglue $(VERSION)
CLEANFILES = lib*.a lib*.dll
+DISTCLEANFILES = $(nodist_libappindicator3sharpglue_12_10_0_la_SOURCES)
+
EXTRA_DIST =
diff --git a/sources/glue/generated.c b/sources/glue/generated.c
deleted file mode 100644
index 98c1fc5..0000000
--- a/sources/glue/generated.c
+++ /dev/null
@@ -1,13 +0,0 @@
-// This file was generated by the Gtk# code generator.
-// Any changes made will be lost if regenerated.
-
-#include <libappindicator/app-indicator.h>
-
-guint appindicator3sharp_appindicator3_indicator_get_parent_offset (void);
-
-guint
-appindicator3sharp_appindicator3_indicator_get_parent_offset (void)
-{
- return (guint)G_STRUCT_OFFSET (AppIndicator, parent);
-}
-