summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2018-05-22 09:31:55 -0400
committerReinhard Tartler <siretart@tauware.de>2018-05-22 09:32:08 -0400
commit20cdf8e56fdcb30e3cc0380c49002b5d507c2f08 (patch)
tree10a93cf3a92ae101f58dc260e32298120156a047
parentb6d0627eeb2242c92c9bac3455d772bb47c3543f (diff)
* Add patch to fix FTBFS with gcc-8 (Closes: #897709)debian/1%2.2+git20170823-6
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/0001-lexertl-Fix-FTBFS-with-gcc-8.patch20
-rw-r--r--debian/patches/series1
3 files changed, 27 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 22bff86..18bbf9b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+aspectc++ (1:2.2+git20170823-6) unstable; urgency=medium
+
+ * Add patch to fix FTBFS with gcc-8 (Closes: #897709)
+
+ -- Reinhard Tartler <siretart@tauware.de> Tue, 22 May 2018 09:31:45 -0400
+
aspectc++ (1:2.2+git20170823-5) unstable; urgency=medium
* Fix typo that resulted in wrong CFLAGS during compilation
diff --git a/debian/patches/0001-lexertl-Fix-FTBFS-with-gcc-8.patch b/debian/patches/0001-lexertl-Fix-FTBFS-with-gcc-8.patch
new file mode 100644
index 0000000..31e6697
--- /dev/null
+++ b/debian/patches/0001-lexertl-Fix-FTBFS-with-gcc-8.patch
@@ -0,0 +1,20 @@
+From: Reinhard Tartler <siretart@tauware.de>
+Date: Tue, 22 May 2018 09:08:00 -0400
+Subject: lexertl: Fix FTBFS with gcc 8
+
+---
+ Puma/extern/lexertl/parser/tokeniser/re_tokeniser_state.hpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Puma/extern/lexertl/parser/tokeniser/re_tokeniser_state.hpp b/Puma/extern/lexertl/parser/tokeniser/re_tokeniser_state.hpp
+index 8434ef1..af58101 100644
+--- a/Puma/extern/lexertl/parser/tokeniser/re_tokeniser_state.hpp
++++ b/Puma/extern/lexertl/parser/tokeniser/re_tokeniser_state.hpp
+@@ -77,7 +77,6 @@ struct basic_re_tokeniser_state
+ _paren_count = rhs_._paren_count;
+ _in_string = rhs_._in_string;
+ _nl_id = rhs_._nl_id;
+- return this;
+ }
+
+ inline bool next(char_type &ch_)
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..b7ef2d2
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-lexertl-Fix-FTBFS-with-gcc-8.patch