summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMattia Rizzolo <mattia@debian.org>2017-08-25 14:39:04 +0200
committerMattia Rizzolo <mattia@debian.org>2017-08-25 15:14:09 +0200
commita5bc102b71b4396817085f4a31d47fda7023d609 (patch)
tree3403110b0baa288ebf49caee9440213e72725f70 /debian
parent4ef79871fb7413959afe8865e5a639b3a99dfe1f (diff)
Replace manual list of architectures and substs with c++|regex
Signed-off-by: Mattia Rizzolo <mattia@debian.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/libaudcore5.symbols19
-rw-r--r--debian/libaudgui5.symbols3
3 files changed, 13 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index a7cedf3..c2caaba 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,12 @@
audacious (3.9-2) UNRELEASED; urgency=medium
+ [ Simon Quigley ]
* Update symbols from build logs.
+ [ Mattia Rizzolo ]
+ * Update symbol files to use c++|regex instead of hardcoding architecture
+ lists or using pkgkde-symbolshelper's subst.
+
-- Simon Quigley <tsimonq2@ubuntu.com> Thu, 24 Aug 2017 11:26:35 -0500
audacious (3.9-1) unstable; urgency=medium
diff --git a/debian/libaudcore5.symbols b/debian/libaudcore5.symbols
index 86461e1..892babc 100644
--- a/debian/libaudcore5.symbols
+++ b/debian/libaudcore5.symbols
@@ -1,4 +1,3 @@
-# SymbolsHelper-Confirmed: 3.9 amd64 arm64 armhf i386 ppc64el
libaudcore.so.5 libaudcore5 #MINVER#
_Z10aud_resumev@Base 3.8
_Z10int_to_stri@Base 3.8
@@ -18,11 +17,7 @@ libaudcore.so.5 libaudcore5 #MINVER#
_Z11str_to_utf8PKci@Base 3.8
_Z11str_tolowerPKc@Base 3.8
_Z11str_toupperPKc@Base 3.9
- (arch=amd64 powerpc s390x powerpcspe x32)_Z11str_vprintfPKcP13__va_list_tag@Base 3.9
- (arch=i386 ppc64el hurd-i386 kfreebsd-i386 ppc64)_Z11str_vprintfPKcPc@Base 3.9
- (arch=arm64 armhf armel)_Z11str_vprintfPKcSt9__va_list@Base 3.9
- (arch=mips mips64el mipsel hppa m68k sparc64)_Z11str_vprintfPKcPv@Base 3.9
- (arch=alpha sh4)_Z11str_vprintfPKc13__va_list_tag@Base 3.9
+ (c++|regex)"^str_vprintf\(char const\*, (__va_list_tag\*?|char\*|std::__va_list|void\*)\)@Base$" 3.9
_Z11strcmp_safePKcS0_i@Base 3.8
_Z11tiny_unlockPc@Base 3.8
_Z12aud_art_dataPK10AudArtItem@Base 3.9
@@ -73,7 +68,7 @@ libaudcore.so.5 libaudcore5 #MINVER#
_Z15filename_expandO9StringBuf@Base 3.8
_Z15filename_to_uriPKc@Base 3.8
_Z15hook_dissociatePKcPFvPvS1_ES1_@Base 3.8
- (subst)_Z15str_format_time{int64_t}@Base 3.8
+ (c++|regex)"^str_format_time\((long|long long)\)@Base$" 3.8
_Z15str_from_localePKci@Base 3.8
_Z15tiny_lock_writePt@Base 3.8
_Z15uri_to_filenamePKcb@Base 3.8
@@ -266,16 +261,16 @@ libaudcore.so.5 libaudcore5 #MINVER#
_ZN7VFSFile12replace_withERS_@Base 3.8
_ZN7VFSFile19set_limit_to_bufferEb@Base 3.8
_ZN7VFSFile4feofEv@Base 3.8
- (subst)_ZN7VFSFile5freadEPv{int64_t}{int64_t}@Base 3.8
- (subst)_ZN7VFSFile5fseekE{int64_t}11VFSSeekType@Base 3.8
+ (c++|regex)"^VFSFile::fread\(void\*, (long|long long), (long|long long)\)@Base$" 3.8
+ (c++|regex)"^VFSFile::fseek\((long|long long), VFSSeekType\)@Base$" 3.8
_ZN7VFSFile5fsizeEv@Base 3.8
_ZN7VFSFile5ftellEv@Base 3.8
_ZN7VFSFile6fflushEv@Base 3.8
- (subst)_ZN7VFSFile6fwriteEPKv{int64_t}{int64_t}@Base 3.8
+ (c++|regex)"^VFSFile::fwrite\(void const\*, (long|long long), (long|long long)\)@Base$" 3.8
_ZN7VFSFile7tmpfileEv@Base 3.8
_ZN7VFSFile8read_allEv@Base 3.8
- (subst)_ZN7VFSFile9copy_fromERS_{int64_t}@Base 3.8
- (subst)_ZN7VFSFile9ftruncateE{int64_t}@Base 3.8
+ (c++|regex)"^VFSFile::copy_from\(VFSFile&, (long|long long)\)@Base$" 3.8
+ (c++|regex)"^VFSFile::ftruncate\((long|long long)\)@Base$" 3.8
_ZN7VFSFile9test_fileEPKc11VFSFileTest@Base 3.8
_ZN7VFSFile9test_fileEPKc11VFSFileTestR6String@Base 3.8
_ZN7VFSFileC1EPKcS1_@Base 3.8
diff --git a/debian/libaudgui5.symbols b/debian/libaudgui5.symbols
index e482ce8..636fd29 100644
--- a/debian/libaudgui5.symbols
+++ b/debian/libaudgui5.symbols
@@ -1,4 +1,3 @@
-# SymbolsHelper-Confirmed: 3.9 amd64 armhf i386
libaudgui.so.5 libaudgui5 #MINVER#
_Z11audgui_initv@Base 3.8
_Z14audgui_cleanupv@Base 3.8
@@ -37,7 +36,7 @@ libaudgui.so.5 libaudgui5 #MINVER#
_Z23audgui_list_delete_rowsP10_GtkWidgetii@Base 3.8
_Z23audgui_list_insert_rowsP10_GtkWidgetii@Base 3.8
_Z23audgui_list_update_rowsP10_GtkWidgetii@Base 3.8
- (subst)_Z23audgui_pixbuf_from_dataPKv{int64_t}@Base 3.8
+ (c++|regex)"^audgui_pixbuf_from_data\(void const\*, (long|long long)\)@Base$" 3.8
_Z23audgui_scaled_image_newP10_GdkPixbuf@Base 3.8
_Z23audgui_scaled_image_setP10_GtkWidgetP10_GdkPixbuf@Base 3.8
_Z24audgui_destroy_on_escapeP10_GtkWidget@Base 3.8