summaryrefslogtreecommitdiff
path: root/src/libaudclient
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2012-09-06 17:32:55 +0200
committerAlessio Treglia <alessio@debian.org>2012-09-06 17:32:55 +0200
commit3c46cd7449c32f71b7b3246b4f32aace3d9e3f84 (patch)
tree0b1f4f501c9251ffbc622508c726e0ae58370fd0 /src/libaudclient
parent5927940f774494d20baf7fc501326c2b084e3846 (diff)
Imported Upstream version 3.3.1
Diffstat (limited to 'src/libaudclient')
-rw-r--r--src/libaudclient/Makefile2
-rw-r--r--src/libaudclient/audctrl.c25
-rw-r--r--src/libaudclient/audctrl.h27
3 files changed, 29 insertions, 25 deletions
diff --git a/src/libaudclient/Makefile b/src/libaudclient/Makefile
index 475e583..52f720d 100644
--- a/src/libaudclient/Makefile
+++ b/src/libaudclient/Makefile
@@ -1,4 +1,4 @@
-LIB = ${LIB_PREFIX}audclient${LIB_SUFFIX}
+SHARED_LIB = ${LIB_PREFIX}audclient${LIB_SUFFIX}
LIB_MAJOR = 2
LIB_MINOR = 0
diff --git a/src/libaudclient/audctrl.c b/src/libaudclient/audctrl.c
index d06a51b..530f877 100644
--- a/src/libaudclient/audctrl.c
+++ b/src/libaudclient/audctrl.c
@@ -1,18 +1,21 @@
/*
- * Audacious: A cross-platform multimedia player
- * Copyright (c) 2007 Ben Tucker
+ * audctrl.c
+ * Copyright 2007-2011 Ben Tucker, William Pitcock, Yoshiki Yazawa,
+ * Matti Hämäläinen, and John Lindgren
*
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; under version 3 of the License.
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
*
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
+ * 1. Redistributions of source code must retain the above copyright notice,
+ * this list of conditions, and the following disclaimer.
*
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ * 2. Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions, and the following disclaimer in the documentation
+ * provided with the distribution.
+ *
+ * This software is provided "as is" and without any warranty, express or
+ * implied. In no event shall the authors be liable for any damages arising from
+ * the use of this software.
*/
#include <stdlib.h>
diff --git a/src/libaudclient/audctrl.h b/src/libaudclient/audctrl.h
index 518c3b7..6e316f8 100644
--- a/src/libaudclient/audctrl.h
+++ b/src/libaudclient/audctrl.h
@@ -1,20 +1,21 @@
/*
- * Audacious: A cross-platform multimedia player
- * Copyright (c) 2007 Ben Tucker
+ * audctrl.h
+ * Copyright 2007-2011 Ben Tucker, William Pitcock, Yoshiki Yazawa,
+ * Matti Hämäläinen, and John Lindgren
*
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; under version 2 of the License.
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
*
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
+ * 1. Redistributions of source code must retain the above copyright notice,
+ * this list of conditions, and the following disclaimer.
*
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
- * 02110-1301, USA.
+ * 2. Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions, and the following disclaimer in the documentation
+ * provided with the distribution.
+ *
+ * This software is provided "as is" and without any warranty, express or
+ * implied. In no event shall the authors be liable for any damages arising from
+ * the use of this software.
*/
#ifndef AUDACIOUS_AUDCTRL_H