summaryrefslogtreecommitdiff
path: root/src/libaudcore/Makefile
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2010-04-09 12:53:33 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2010-04-09 12:53:33 +0200
commit56ad9eb46da6e9b941795b17fb4fa18b6f75c4ae (patch)
tree506dd25abf80e476198b0dd973455050e6f6ddf8 /src/libaudcore/Makefile
Imported Upstream version 2.3
Diffstat (limited to 'src/libaudcore/Makefile')
-rw-r--r--src/libaudcore/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/libaudcore/Makefile b/src/libaudcore/Makefile
new file mode 100644
index 0000000..eaae62c
--- /dev/null
+++ b/src/libaudcore/Makefile
@@ -0,0 +1,40 @@
+LIB = ${LIB_PREFIX}audcore${LIB_SUFFIX}
+LIB_MAJOR = 1
+LIB_MINOR = 0
+
+SRCS = audio.c \
+ audstrings.c \
+ index.c \
+ stringpool.c \
+ tuple.c \
+ tuple_compiler.c \
+ tuple_formatter.c \
+ vfs.c \
+ vfs_buffer.c \
+ vfs_buffered_file.c \
+ vfs_common.c \
+ md5.c \
+ log.c
+
+INCLUDES = audio.h \
+ audstrings.h \
+ index.h \
+ stringpool.h \
+ tuple.h \
+ tuple_compiler.h \
+ tuple_formatter.h \
+ vfs.h \
+ vfs_buffer.h \
+ vfs_buffered_file.h \
+ md5.h \
+ log.h
+
+include ../../buildsys.mk
+include ../../extra.mk
+
+includesubdir = libaudcore
+
+CPPFLAGS += ${LIB_CPPFLAGS} ${CFLAGS} -D_AUDACIOUS_CORE -I.. -I../..
+CFLAGS += ${LIB_CFLAGS} ${GLIB_CFLAGS} ${MOWGLI_CFLAGS}
+
+LIBS += ${GLIB_LIBS} ${MOWGLI_LIBS}