summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure287
1 files changed, 227 insertions, 60 deletions
diff --git a/configure b/configure
index 1920d08..765caf1 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for audacious 3.7.2.
+# Generated by GNU Autoconf 2.69 for audacious 3.8-beta2.
#
#
# Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@@ -579,8 +579,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='audacious'
PACKAGE_TARNAME='audacious'
-PACKAGE_VERSION='3.7.2'
-PACKAGE_STRING='audacious 3.7.2'
+PACKAGE_VERSION='3.8-beta2'
+PACKAGE_STRING='audacious 3.8-beta2'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
@@ -640,6 +640,7 @@ plugindir
VALGRIND_FRIENDLY
USE_DBUS
have_dbus
+BUILDSTAMP
POSUB
LTLIBINTL
LIBINTL
@@ -736,6 +737,7 @@ build_os
build_vendor
build_cpu
build
+COPYRIGHT
target_alias
host_alias
build_alias
@@ -787,7 +789,6 @@ with_libiconv_prefix
enable_nls
with_libintl_prefix
with_buildstamp
-enable_text_console
enable_dbus
enable_valgrind
'
@@ -1364,7 +1365,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures audacious 3.7.2 to adapt to many kinds of systems.
+\`configure' configures audacious 3.8-beta2 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1430,7 +1431,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of audacious 3.7.2:";;
+ short | recursive ) echo "Configuration of audacious 3.8-beta2:";;
esac
cat <<\_ACEOF
@@ -1443,7 +1444,6 @@ Optional Features:
--enable-qt Enable Qt support (default=disabled)
--disable-rpath do not hardcode runtime library paths
--disable-nls do not use Native Language Support
- --enable-text-console Enable text console for MS-Windows hosts
--disable-dbus Disable D-Bus support (default=enabled)
--enable-valgrind Valgrind analysis support (default=disabled)
@@ -1563,7 +1563,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-audacious configure 3.7.2
+audacious configure 3.8-beta2
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2031,7 +2031,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by audacious $as_me 3.7.2, which was
+It was created by audacious $as_me 3.8-beta2, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2393,11 +2393,14 @@ cat >>confdefs.h <<_ACEOF
_ACEOF
+COPYRIGHT="Copyright (C) 2001-2016 Audacious developers and others"
+
cat >>confdefs.h <<_ACEOF
-#define COPYRIGHT "Copyright © 2001-2016 Audacious developers and others"
+#define COPYRIGHT "$COPYRIGHT"
_ACEOF
+
ac_aux_dir=
for ac_dir in build-aux "$srcdir"/build-aux; do
if test -f "$ac_dir/install-sh"; then
@@ -4575,12 +4578,12 @@ esac
if test "x$GCC" = "xyes"; then
- CFLAGS="$CFLAGS -std=gnu99 -ffast-math -Wall -pipe -Wno-deprecated-declarations"
+ CFLAGS="$CFLAGS -std=gnu99 -ffast-math -Wall -pipe"
if test "x$HAVE_DARWIN" = "xyes"; then
- CXXFLAGS="$CXXFLAGS -stdlib=libc++ -std=gnu++11 -ffast-math -Wall -pipe -Wno-deprecated-declarations"
+ CXXFLAGS="$CXXFLAGS -stdlib=libc++ -std=gnu++11 -ffast-math -Wall -pipe"
LDFLAGS="$LDFLAGS -lc++ -stdlib=libc++"
else
- CXXFLAGS="$CXXFLAGS -std=gnu++11 -ffast-math -Wall -pipe -Wno-deprecated-declarations"
+ CXXFLAGS="$CXXFLAGS -std=gnu++11 -ffast-math -Wall -pipe"
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the C/C++ compiler supports -Wtype-limits" >&5
@@ -5809,8 +5812,9 @@ $as_echo "no" >&6; }
fi
-# Extract the first word of "ar", so it can be a program name with args.
-set dummy ar; ac_word=$2
+if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}ar", so it can be a program name with args.
+set dummy ${ac_tool_prefix}ar; ac_word=$2
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
if ${ac_cv_path_AR+:} false; then :
@@ -5849,8 +5853,66 @@ $as_echo "no" >&6; }
fi
-# Extract the first word of "ranlib", so it can be a program name with args.
-set dummy ranlib; ac_word=$2
+fi
+if test -z "$ac_cv_path_AR"; then
+ ac_pt_AR=$AR
+ # Extract the first word of "ar", so it can be a program name with args.
+set dummy ar; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_ac_pt_AR+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $ac_pt_AR in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_ac_pt_AR="$ac_pt_AR" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_ac_pt_AR="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+ac_pt_AR=$ac_cv_path_ac_pt_AR
+if test -n "$ac_pt_AR"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_AR" >&5
+$as_echo "$ac_pt_AR" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+ if test "x$ac_pt_AR" = x; then
+ AR=""
+ else
+ case $cross_compiling:$ac_tool_warned in
+yes:)
+{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+ac_tool_warned=yes ;;
+esac
+ AR=$ac_pt_AR
+ fi
+else
+ AR="$ac_cv_path_AR"
+fi
+
+if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}ranlib", so it can be a program name with args.
+set dummy ${ac_tool_prefix}ranlib; ac_word=$2
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
if ${ac_cv_path_RANLIB+:} false; then :
@@ -5889,8 +5951,66 @@ $as_echo "no" >&6; }
fi
-# Extract the first word of "windres", so it can be a program name with args.
-set dummy windres; ac_word=$2
+fi
+if test -z "$ac_cv_path_RANLIB"; then
+ ac_pt_RANLIB=$RANLIB
+ # Extract the first word of "ranlib", so it can be a program name with args.
+set dummy ranlib; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_ac_pt_RANLIB+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $ac_pt_RANLIB in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_ac_pt_RANLIB="$ac_pt_RANLIB" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_ac_pt_RANLIB="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+ac_pt_RANLIB=$ac_cv_path_ac_pt_RANLIB
+if test -n "$ac_pt_RANLIB"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_RANLIB" >&5
+$as_echo "$ac_pt_RANLIB" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+ if test "x$ac_pt_RANLIB" = x; then
+ RANLIB=""
+ else
+ case $cross_compiling:$ac_tool_warned in
+yes:)
+{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+ac_tool_warned=yes ;;
+esac
+ RANLIB=$ac_pt_RANLIB
+ fi
+else
+ RANLIB="$ac_cv_path_RANLIB"
+fi
+
+if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}windres", so it can be a program name with args.
+set dummy ${ac_tool_prefix}windres; ac_word=$2
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
if ${ac_cv_path_WINDRES+:} false; then :
@@ -5929,6 +6049,63 @@ $as_echo "no" >&6; }
fi
+fi
+if test -z "$ac_cv_path_WINDRES"; then
+ ac_pt_WINDRES=$WINDRES
+ # Extract the first word of "windres", so it can be a program name with args.
+set dummy windres; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_ac_pt_WINDRES+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $ac_pt_WINDRES in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_ac_pt_WINDRES="$ac_pt_WINDRES" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_ac_pt_WINDRES="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+ac_pt_WINDRES=$ac_cv_path_ac_pt_WINDRES
+if test -n "$ac_pt_WINDRES"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_WINDRES" >&5
+$as_echo "$ac_pt_WINDRES" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+ if test "x$ac_pt_WINDRES" = x; then
+ WINDRES=""
+ else
+ case $cross_compiling:$ac_tool_warned in
+yes:)
+{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+ac_tool_warned=yes ;;
+esac
+ WINDRES=$ac_pt_WINDRES
+ fi
+else
+ WINDRES="$ac_cv_path_WINDRES"
+fi
+
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing pthread_create" >&5
$as_echo_n "checking for library containing pthread_create... " >&6; }
@@ -6810,19 +6987,6 @@ fi
done
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for /proc/self/exe" >&5
-$as_echo_n "checking for /proc/self/exe... " >&6; }
-if test -e "/proc/self/exe" ; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
-
-$as_echo "#define HAVE_PROC_SELF_EXE 1" >>confdefs.h
-
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
if test "X$prefix" = "XNONE"; then
@@ -8510,16 +8674,21 @@ else
/* end confdefs.h. */
#include <libintl.h>
-$gt_revision_test_code
+#ifndef __GNU_GETTEXT_SUPPORTED_REVISION
extern int _nl_msg_cat_cntr;
extern int *_nl_domain_bindings;
+#define __GNU_GETTEXT_SYMBOL_EXPRESSION (_nl_msg_cat_cntr + *_nl_domain_bindings)
+#else
+#define __GNU_GETTEXT_SYMBOL_EXPRESSION 0
+#endif
+$gt_revision_test_code
int
main ()
{
bindtextdomain ("", "");
-return * gettext ("")$gt_expression_test_code + _nl_msg_cat_cntr + *_nl_domain_bindings
+return * gettext ("")$gt_expression_test_code + __GNU_GETTEXT_SYMBOL_EXPRESSION
;
return 0;
@@ -9272,20 +9441,25 @@ else
/* end confdefs.h. */
#include <libintl.h>
-$gt_revision_test_code
+#ifndef __GNU_GETTEXT_SUPPORTED_REVISION
extern int _nl_msg_cat_cntr;
extern
#ifdef __cplusplus
"C"
#endif
const char *_nl_expand_alias (const char *);
+#define __GNU_GETTEXT_SYMBOL_EXPRESSION (_nl_msg_cat_cntr + *_nl_expand_alias (""))
+#else
+#define __GNU_GETTEXT_SYMBOL_EXPRESSION 0
+#endif
+$gt_revision_test_code
int
main ()
{
bindtextdomain ("", "");
-return * gettext ("")$gt_expression_test_code + _nl_msg_cat_cntr + *_nl_expand_alias ("")
+return * gettext ("")$gt_expression_test_code + __GNU_GETTEXT_SYMBOL_EXPRESSION
;
return 0;
@@ -9304,20 +9478,25 @@ rm -f core conftest.err conftest.$ac_objext \
/* end confdefs.h. */
#include <libintl.h>
-$gt_revision_test_code
+#ifndef __GNU_GETTEXT_SUPPORTED_REVISION
extern int _nl_msg_cat_cntr;
extern
#ifdef __cplusplus
"C"
#endif
const char *_nl_expand_alias (const char *);
+#define __GNU_GETTEXT_SYMBOL_EXPRESSION (_nl_msg_cat_cntr + *_nl_expand_alias (""))
+#else
+#define __GNU_GETTEXT_SYMBOL_EXPRESSION 0
+#endif
+$gt_revision_test_code
int
main ()
{
bindtextdomain ("", "");
-return * gettext ("")$gt_expression_test_code + _nl_msg_cat_cntr + *_nl_expand_alias ("")
+return * gettext ("")$gt_expression_test_code + __GNU_GETTEXT_SYMBOL_EXPRESSION
;
return 0;
@@ -9453,32 +9632,18 @@ LIBS="$LIBS $LIBINTL"
# Check whether --with-buildstamp was given.
if test "${with_buildstamp+set}" = set; then :
- withval=$with_buildstamp;
-cat >>confdefs.h <<_ACEOF
-#define BUILDSTAMP "$withval"
-_ACEOF
-
+ withval=$with_buildstamp; BUILDSTAMP="$withval"
else
-
-cat >>confdefs.h <<_ACEOF
-#define BUILDSTAMP "unknown build"
-_ACEOF
-
+ BUILDSTAMP="unknown build"
fi
-# Check whether --enable-text-console was given.
-if test "${enable_text_console+set}" = set; then :
- enableval=$enable_text_console; use_text_console=$withval
-else
- use_text_console=no
-fi
+cat >>confdefs.h <<_ACEOF
+#define BUILDSTAMP "$BUILDSTAMP"
+_ACEOF
-if test "x$HAVE_MSWINDOWS" = "xyes" && test "x$use_text_console" = "xno" ; then
- LDFLAGS="$LDFLAGS -Wl,-subsystem,windows"
-fi
# Check whether --enable-dbus was given.
@@ -9569,7 +9734,7 @@ CPPFLAGS="$CPPFLAGS -include config.h"
### ---------------------------------------------------------------------------
-ac_config_files="$ac_config_files audacious.pc buildsys.mk extra.mk man/audtool.1 man/audacious.1 src/libaudcore/audio.h src/libaudcore/tinylock.h"
+ac_config_files="$ac_config_files audacious.pc buildsys.mk extra.mk man/audtool.1 man/audacious.1 src/libaudcore/audio.h src/libaudcore/tinylock.h win32/audacious.nsi win32/override/README.txt"
cat >confcache <<\_ACEOF
@@ -10201,7 +10366,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by audacious $as_me 3.7.2, which was
+This file was extended by audacious $as_me 3.8-beta2, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -10267,7 +10432,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-audacious config.status 3.7.2
+audacious config.status 3.8-beta2
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
@@ -10410,6 +10575,8 @@ do
"man/audacious.1") CONFIG_FILES="$CONFIG_FILES man/audacious.1" ;;
"src/libaudcore/audio.h") CONFIG_FILES="$CONFIG_FILES src/libaudcore/audio.h" ;;
"src/libaudcore/tinylock.h") CONFIG_FILES="$CONFIG_FILES src/libaudcore/tinylock.h" ;;
+ "win32/audacious.nsi") CONFIG_FILES="$CONFIG_FILES win32/audacious.nsi" ;;
+ "win32/override/README.txt") CONFIG_FILES="$CONFIG_FILES win32/override/README.txt" ;;
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
esac