summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-22 11:55:31 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-22 11:55:31 +0000
commit9d4eb04ba356aac58d96bbb2bdf81bd69ba68122 (patch)
treeb0fa685896e83e0158824c69e9101f33c4e3c1b1
parent4b19c2885bae85dee45ecfc3cfcd8d503d3f3e23 (diff)
parent5ea5146c77528ffca1aa188ef2d62a4ba7f0c721 (diff)
Merge from sid [dgit]
-rw-r--r--.gitignore9
-rw-r--r--debian/.cvsignore3
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules4
4 files changed, 12 insertions, 12 deletions
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 5e726ef..0000000
--- a/.gitignore
+++ /dev/null
@@ -1,9 +0,0 @@
-*.o
-*~
-authbind
-helper
-libauthbind.o
-libauthbind.so.1.0
-debian/files
-debian/substvars
-debian/tmp
diff --git a/debian/.cvsignore b/debian/.cvsignore
deleted file mode 100644
index db09c07..0000000
--- a/debian/.cvsignore
+++ /dev/null
@@ -1,3 +0,0 @@
-files
-substvars
-tmp
diff --git a/debian/changelog b/debian/changelog
index 1356606..57e2e09 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,14 @@ authbind (2.1.2) unstable; urgency=low
--
+authbind (2.1.1+nmu1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Fix mtimes before building binary packages to produce reproducible output
+ Based on patch by akira (Closes: #792945)
+
+ -- Johannes Schauer <josch@debian.org> Sun, 26 Jul 2015 11:23:35 +0200
+
authbind (2.1.1) unstable; urgency=low
* Manpage has an example of which files will be checked and read
diff --git a/debian/rules b/debian/rules
index 96d90aa..c9091ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,6 +29,8 @@ minor=0
arch = $(shell dpkg --print-architecture)
+export SOURCE_DATE_EPOCH = $(shell date -d "$$(dpkg-parsechangelog --count 1 -SDate)" +%s)
+
INSTALL = install
INSTALL_FILE = $(INSTALL) -p -o root -g root -m 644
INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
@@ -90,6 +92,8 @@ binary-arch: checkroot build
dpkg-gencontrol -isp
chown -R root.root debian/tmp
chmod -R g-ws debian/tmp
+ find debian/tmp -newermt "@$$SOURCE_DATE_EPOCH" -print0 | \
+ xargs -0r touch --no-dereference --date="@$$SOURCE_DATE_EPOCH"
dpkg --build debian/tmp ..
binary: binary-indep binary-arch