summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2016-06-26 19:13:10 +0200
committerAlfred E. Heggestad <aeh@db.org>2016-06-26 19:13:10 +0200
commit3a21a4d3217afee7903dc53bffe3d37da0ff2567 (patch)
tree30179a7e06600e7ef28f3345426b544fb2a8676d
parentdb7f0c1684bc3318e516d838445956ed359d597d (diff)
pulse: enable auto-detection of pulse.so module
-rw-r--r--docs/README1
-rw-r--r--mk/modules.mk7
2 files changed, 7 insertions, 1 deletions
diff --git a/docs/README b/docs/README
index a09fdf2..5f72cc9 100644
--- a/docs/README
+++ b/docs/README
@@ -191,6 +191,7 @@ opus OPUS Interactive audio codec
oss Open Sound System (OSS) audio driver
plc Packet Loss Concealment (PLC) using spandsp
portaudio Portaudio driver
+pulse Pulseaudio driver
presence Presence module
qtcapture Apple QTCapture video source driver
quicktime Apple Quicktime video source driver (deprecated)
diff --git a/mk/modules.mk b/mk/modules.mk
index 8f4f288..b103924 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -1,7 +1,7 @@
#
# modules.mk
#
-# Copyright (C) 2010 Creytiv.com
+# Copyright (C) 2010 - 2016 Creytiv.com
#
# External libraries:
#
@@ -37,6 +37,7 @@
# USE_OSS OSS audio driver
# USE_PLC Packet Loss Concealment
# USE_PORTAUDIO Portaudio audio driver
+# USE_PULSE Pulseaudio audio driver
# USE_SDL libSDL video output
# USE_SILK SILK (Skype) audio codec
# USE_SNDFILE sndfile wav dumper
@@ -136,6 +137,7 @@ USE_PLC := $(shell [ -f $(SYSROOT)/include/spandsp/plc.h ] || \
USE_PORTAUDIO := $(shell [ -f $(SYSROOT)/local/include/portaudio.h ] || \
[ -f $(SYSROOT)/include/portaudio.h ] || \
[ -f $(SYSROOT_ALT)/include/portaudio.h ] && echo "yes")
+USE_PULSE := $(shell pkg-config --exists libpulse && echo "yes")
USE_SDL := $(shell [ -f $(SYSROOT)/include/SDL/SDL.h ] || \
[ -f $(SYSROOT)/local/include/SDL/SDL.h ] || \
[ -f $(SYSROOT_ALT)/include/SDL/SDl.h ] && echo "yes")
@@ -377,6 +379,9 @@ endif
ifneq ($(USE_PORTAUDIO),)
MODULES += portaudio
endif
+ifneq ($(USE_PULSE),)
+MODULES += pulse
+endif
ifneq ($(USE_SDL),)
MODULES += sdl
endif