summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2014-02-09 12:01:28 +0100
committerAlfred E. Heggestad <aeh@db.org>2014-02-09 12:01:28 +0100
commita49ed6fdade55f1c3540dcf61d3ca2fce0d6f10d (patch)
treeebead9b87ae2e44b67308dbe6b43bb4d2ea25cff
parent98bf08bdcf2edd9d397f32650a8bfe62186fbecf (diff)
debian: upgrade files and fix lintian warnings
-rw-r--r--debian/compat2
-rw-r--r--debian/control21
-rw-r--r--debian/copyright34
-rwxr-xr-xdebian/rules13
4 files changed, 53 insertions, 17 deletions
diff --git a/debian/compat b/debian/compat
index 45a4fb7..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-8
+9
diff --git a/debian/control b/debian/control
index fde2419..3e0a017 100644
--- a/debian/control
+++ b/debian/control
@@ -2,20 +2,19 @@ Source: baresip
Section: comm
Priority: optional
Maintainer: Alfred E. Heggestad <aeh@db.org>
-Build-Depends: debhelper (>= 4.0.0), librem-dev (>= 0.4.5), libre-dev (>= 0.4.5), libasound2-dev, libavformat-dev, libavdevice-dev
-Standards-Version: 3.6.2
-Homepage: http://www.creytiv.com/baresip.html
+Standards-Version: 3.9.5
+Build-Depends: debhelper (>= 9.20120311), librem-dev (>= 0.4.5), libre-dev (>= 0.4.5), libasound2-dev, libavformat-dev, libavdevice-dev
+Homepage: http://www.creytiv.com/
Package: baresip
Architecture: any
-Depends: ${shlibs:Depends}, librem (>= 0.4.5), libre (>= 0.4.5)
+Depends: ${shlibs:Depends}, ${misc:Depends}, librem (>= 0.4.5), libre (>= 0.4.5)
Description: Modular SIP User-Agent with audio and video support
- .
Design goals:
.
- - Minimalistic and modular VoIP client
- - SIP, SDP, RTP/RTCP, STUN/TURN/ICE
- - IPv4 and IPv6 support
- - RFC compliant
- - Robust, fast, low footprint
- - Portable C89 and C99 source code
+ Minimalistic and modular VoIP client
+ SIP, SDP, RTP/RTCP, STUN/TURN/ICE
+ IPv4 and IPv6 support
+ RFC compliant
+ Robust, fast, low footprint
+ Portable C89 and C99 source code
diff --git a/debian/copyright b/debian/copyright
index bbb27a9..f56a8be 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -2,8 +2,36 @@ This package was debianized by Alfred E. Heggestad <aeh@db.org>
It was downloaded from www.creytiv.com
-Copyright Holder: Creytiv.com
-License:
+Copyright (c) 2010 - 2014, Alfred E. Heggestad
+Copyright (c) 2010 - 2014, Richard Aas
+Copyright (c) 2010 - 2014, Creytiv.com
+All rights reserved.
-Distributed under BSD license
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+3. Neither the name of the Creytiv.com nor the names of its contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/debian/rules b/debian/rules
index b4edc3b..c2f36a0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,6 +11,9 @@
BARESIP_FLAGS := MOD_AUTODETECT=1
+EXTRA_CFLAGS:="$(shell dpkg-buildflags --get CFLAGS)"
+EXTRA_LFLAGS:="$(shell dpkg-buildflags --get LDFLAGS)"
+
configure: configure-stamp
configure-stamp:
@@ -22,14 +25,16 @@ build: build-stamp
build-stamp: configure-stamp
dh_testdir
- $(MAKE) RELEASE=1 $(BARESIP_FLAGS) DESTDIR=$(CURDIR)/debian/baresip
+ $(MAKE) RELEASE=1 $(BARESIP_FLAGS) DESTDIR=$(CURDIR)/debian/baresip \
+ EXTRA_CFLAGS=$(EXTRA_CFLAGS) \
+ EXTRA_LFLAGS=$(EXTRA_LFLAGS)
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
- -$(MAKE) clean
+ $(MAKE) clean
dh_clean
install: build
@@ -75,5 +80,9 @@ binary-arch: build install
dh_md5sums
dh_builddeb
+build-arch: build
+
+build-indep: build
+
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure