diff options
author | Alfred E. Heggestad <aeh@db.org> | 2015-10-04 21:24:31 +0200 |
---|---|---|
committer | Alfred E. Heggestad <aeh@db.org> | 2015-10-04 21:24:31 +0200 |
commit | 5cbd1d17177236f7c4515f077c18d328c76af9b1 (patch) | |
tree | 287a08249ce9a545318c67985688902e221b4f6d /Makefile | |
parent | 26b1c86e32abc1d2543d667c80b3532e6e178c16 (diff) |
test: use new sipsrv from retest
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -49,6 +49,9 @@ CXXFLAGS += -I$(LIBREM_PATH)/include CXXFLAGS += -I$(SYSROOT)/local/include/rem -I$(SYSROOT)/include/rem CXXFLAGS += $(EXTRA_CXXFLAGS) +# XXX: common for C/C++ +CPPFLAGS += -DHAVE_INTTYPES_H + ifneq ($(LIBREM_PATH),) SPLINT_OPTIONS += -I$(LIBREM_PATH)/include CLANG_OPTIONS += -I$(LIBREM_PATH)/include @@ -195,7 +198,7 @@ $(BUILD)/%.o: %.c $(BUILD) Makefile $(APP_MK) $(BUILD)/%.o: %.cpp $(BUILD) Makefile $(APP_MK) @echo " CXX $@" - @$(CXX) $(CXXFLAGS) -c $< -o $@ $(DFLAGS) + @$(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $< -o $@ $(DFLAGS) $(BUILD)/%.o: %.m $(BUILD) Makefile $(APP_MK) @echo " OC $@" @@ -206,7 +209,7 @@ $(BUILD)/%.o: %.S $(BUILD) Makefile $(APP_MK) @$(CC) $(CFLAGS) -c $< -o $@ $(DFLAGS) $(BUILD): Makefile - @mkdir -p $(BUILD)/src $(MOD_BLD) $(BUILD)/test + @mkdir -p $(BUILD)/src $(MOD_BLD) $(BUILD)/test/mock @touch $@ install: $(BIN) $(MOD_BINS) |