summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2015-09-30 22:31:46 +0200
committerAlfred E. Heggestad <aeh@db.org>2015-09-30 22:31:54 +0200
commita24ade0a3bdede676c4c85198ed3f1c000efaeff (patch)
tree4852712930cc37fdfe9a5f9c99fcd1cd8f4392d6 /Makefile
parent3ba837ff863b6fcce6ebfc22f9c79eaf8d82fadb (diff)
test: added a test for C++ api compatibility
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e7e89b3..ebf3547 100644
--- a/Makefile
+++ b/Makefile
@@ -118,6 +118,7 @@ APP_OBJS := $(OBJS) $(patsubst %.c,$(BUILD)/src/%.o,$(APP_SRCS)) $(MOD_OBJS)
LIB_OBJS := $(OBJS) $(MOD_OBJS)
TEST_OBJS := $(patsubst %.c,$(BUILD)/test/%.o,$(filter %.c,$(TEST_SRCS)))
+TEST_OBJS += $(patsubst %.cpp,$(BUILD)/test/%.o,$(filter %.cpp,$(TEST_SRCS)))
ifneq ($(LIBREM_PATH),)
LIBS += -L$(LIBREM_PATH)
@@ -192,6 +193,10 @@ $(BUILD)/%.o: %.c $(BUILD) Makefile $(APP_MK)
@echo " CC $@"
@$(CC) $(CFLAGS) -c $< -o $@ $(DFLAGS)
+$(BUILD)/%.o: %.cpp $(BUILD) Makefile $(APP_MK)
+ @echo " CXX $@"
+ @$(CXX) $(CXXFLAGS) -c $< -o $@ $(DFLAGS)
+
$(BUILD)/%.o: %.m $(BUILD) Makefile $(APP_MK)
@echo " OC $@"
@$(CC) $(CFLAGS) $(OBJCFLAGS) -c $< -o $@ $(DFLAGS)