summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2018-06-03 20:28:56 +0530
committerVasudev Kamath <vasudev@copyninja.info>2018-06-03 20:28:56 +0530
commitfb1dcaf66b36132858f3bb89d01d41c414a98bba (patch)
treea9d7e4a6bdcf6847b7fb619733c58d10f4cfcb33 /Makefile
parent310061b6c7305400010f862c6ff5f6cbe94747be (diff)
Use -D_GNU_SOURCE for gcc-7 compatibility
baresip fails to build with gcc-7 because libdirectfb-dev needs to know the size of struct timespec, which is an opaque type unless we're using GNU extensions, but libre-dev sets -std=c99. Adjust cflags to enable _GNU_SOURCE. Bug-Debian: https://bugs.debian.org/872406 Last-Update: 2017-08-26 Gbp-Pq: Name 1001_gcc7_compat.patch
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a1a9d1e..357a14a 100644
--- a/Makefile
+++ b/Makefile
@@ -49,6 +49,7 @@ endif
CFLAGS += -I. -Iinclude -I$(LIBRE_INC) -I$(SYSROOT)/include
CFLAGS += -I$(LIBREM_PATH)/include
CFLAGS += -I$(SYSROOT)/local/include/rem -I$(SYSROOT)/include/rem
+CFLAGS += -D_GNU_SOURCE
CXXFLAGS += -I. -Iinclude -I$(LIBRE_INC)
CXXFLAGS += -I$(LIBREM_PATH)/include